Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

error installing ODoo on linuxmint 17

By
eugenio
on 10/13/14, 11:11 AM 2,447 views

I tried install Odoo like one post here:

# echo "deb http://nightly.openerp.com/8.0/nightly/deb/ ./" >> /etc/apt/sources.list

# apt-get update

# apt-get install odoo

# service odoo start

But when i try to go localhost:8069 have an error: 

Internal Server Error

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there is an error in the application.

 

Iḿ newbie with this software, and have not idea how can i solve this.

It's installed in a clean Linuxmint 17 64bits cinnamon. 

Tried with safari and chrome and have the same error. 

thanks

6

swapnil wagh

--swapnil wagh--
1559
| 6 5 8
Pune, India
--swapnil wagh--

My name is Swapnil A. Wagh. I studied Master Of computer Science and work as a Software Engineer. I’m a technology enthusiast and always eager to learn new and exciting technologies. I’m constantly looking for innovative solutions to age-old problems that push the limits of what we conceive to be possible.

swapnil wagh
On 10/13/14, 11:49 AM

Please check server log generally its located at /var/log/openerp/openerp-server.log. There might be any python package missing.

0
eugenio
On 10/13/14, 11:35 AM

the server log: 

a lot of thanks for this help, odoo is the last software i need for migrate 100% from windows to linux :-)

Hi, edit the answer, in my computer, the instructions for install the last version of odoo don't work. Finally i can install odoo doing this (don't know if is the better way, i believe can help others).

Install postgresql with terminal

$ sudo apt-get install postgresql

Password for postgres user

$ sudo -u postgres psql postgres

postgres=# \password postgres  (write your password when terminal say)

 

(ctrl +D for exit)

Create a user as my linuxmint user:

$ sudo -u postgres createuser --superuser $USER ($USER automatically is your linux user)

$ sudo -u postgres psql (for change the new user password)

postgres=# \password USUARIO (change USUARIO/USER for your linux user and write your password)

CTRL + D for exit

Next, I download the .deb package from Odoo, change the permission of the file for all to write and read (don't know if necessary), then click and install. Next in terminal, write:

sudo su (for superuser access)

sudo service odoo start (must be OK, you can test with sudo service odoo status)

Go for your internet browser and write: localhost:8069, create the database following the instructions, and next, create one user for your Odoo company.

For me, it was OK and running well, please, if somebody can say if something is wrong it will can help others with same problem.

 

 

 

 

 

 

 

0

Ludo - Neobis

--Ludo - Neobis--
2387
| 2 2 5
Hoogvliet, Netherlands
--Ludo - Neobis--

Developer

Ludo - Neobis
On 10/13/14, 11:30 AM

What does your log-file tell you about the error? How do you run the server, using a deamon or manually on the commandline?

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 10/13/14, 11:11 AM
Seen: 2447 times
Last updated: 3/16/15, 8:10 AM