Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error in Everyday::::error: [Errno 98] Address already in use

By
aci aisha
on 2/2/15, 11:34 PM 1,092 views

Friends,

I run odoo 8 in eclipse..

I run as open-erp server > run as > python-run..

I stop it using stop button when i stop my work..

Next day i try to run odoo but it cause the following error every day...

error: [Errno 98] Address already in use

Then i go to terminal and type as follows & my error solved..

abc02@amz02-desktop:~$ ps aux|grep odoo
odoo      1143  0.0  1.7  80640 34896 ?        Sl   09:36   0:00 python /opt/odoo/odoo-server/openerp-server -c /etc/odoo-server.conf
abc02     2808  0.0  0.0   4688   820 pts/0    S+   09:47   0:00 grep --color=auto odoo
abc02@amz02-desktop:~$ sudo kill -9 1143
[sudo] password for abc02: 

BUT IT IS VERY DIFFICULT TO DO THIS EVERYDAY!!!

Can u help me???

Thankss

2

Hardikgiri Goswami

--Hardikgiri Goswami--
1123
| 2 1 5
Rajkot, India
--Hardikgiri Goswami--

OpenERP/Odoo Customization/Integration Expert / Python Programmer

Skype ID : hardikgiri.goswami

Hardikgiri Goswami
On 2/3/15, 4:36 AM

Hello Aisha,

please refer this link for start the odoo perfectly for development perpose. https://www.odoo.com/forum/help-1/question/how-can-i-restart-odoo-without-creating-a-new-instance-each-time-73686#answer-73696

Click here

This link is not available Mr

aci aisha
on 2/3/15, 11:22 PM

Just click on "click here" link

Hardikgiri Goswami
on 2/3/15, 11:54 PM
0

Ivan

--Ivan--
3210
| 5 3 6
Jakarta, Indonesia
--Ivan--
Ivan
On 2/3/15, 12:00 AM

Your odoo service is in auto-start.  If you are using Ubuntu you can remove the autostart using the instruction here.

Try it.. But error occured as follows, sudo update-rc.d tomcat disable

aci aisha
on 2/3/15, 12:34 AM

tomcat is NOT the name of your service. You need to find out what is odoo's service name. It is usually placed in /etc/init.d/ folder.

Ivan
on 2/3/15, 1:03 AM

I find a odoo-server file in /etc/init.d Is'nt it??

aci aisha
on 2/3/15, 4:18 AM

Most probably. I wouldn't be able to confirm 100% it depends on how your environment is set-up for the first time. Try to disable it and see if you still get the address conflict issue. If it is not the right service, you can enable it again using sudo update.rc-d XXXX enable

Ivan
on 2/3/15, 6:11 AM
-1

deep

--deep--
1617
| 5 4 7
Bengaluru, India
--deep--

Techno-Functional Associate with 6+ years of experience in Odoo (formerly known as OpenERP).

deep
On 2/3/15, 2:47 AM

One or more process of Odoo must be running behind... It happens when the previous process is not stopped properly before restarting the new one..

Try this comand in the Terminal:

ps xa | grep openerp-server

this command will list out all the process running for the server, if you find more than one process, you can terminate that process, using

kill -9 [process_ID]

 

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 2/2/15, 11:34 PM
Seen: 1092 times
Last updated: 3/16/15, 8:10 AM