Odoo Help


This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Error getting while installing modules on Odoo

on 8/6/14, 1:53 AM 1,067 views

Hello All,

I had a problem while installing modules on the odoo server. Always I'm getting this error, Given below the error

OpenERP Server Error

Traceback (most recent call last): File "/opt/odoo/odoo-server/openerp/http.py", line 476, in _handle_exception return super(JsonRequest, self)._handle_exception(exception) File "/opt/odoo/odoo-server/openerp/http.py", line 495, in dispatch result = self._call_function(**self.params) File "/opt/odoo/odoo-server/openerp/http.py", line 311, in _call_function return checked_call(self.db, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/service/model.py", line 113, in wrapper return f(dbname, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/http.py", line 308, in checked_call return self.endpoint(*a, **kw) File "/opt/odoo/odoo-server/openerp/http.py", line 685, in __call__ return self.method(*args, **kw) File "/opt/odoo/odoo-server/openerp/http.py", line 360, in response_wrap response = f(*args, **kw) File "/opt/odoo/odoo-server/addons/web/controllers/main.py", line 987, in call_button action = self._call_kw(model, method, args, {}) File "/opt/odoo/odoo-server/addons/web/controllers/main.py", line 975, in _call_kw return getattr(request.registry.get(model), method)(request.cr, request.uid, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/api.py", line 204, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/addons/base/module/module.py", line 450, in button_immediate_install return self._button_immediate_function(cr, uid, ids, self.button_install, context=context) File "/opt/odoo/odoo-server/openerp/api.py", line 204, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/addons/base/module/module.py", line 497, in _button_immediate_function registry = openerp.modules.registry.RegistryManager.new(cr.dbname, update_module=True) File "/opt/odoo/odoo-server/openerp/modules/registry.py", line 322, in new openerp.modules.load_modules(registry._db, force_demo, status, update_module) File "/opt/odoo/odoo-server/openerp/modules/loading.py", line 357, in load_modules loaded_modules, update_module) File "/opt/odoo/odoo-server/openerp/modules/loading.py", line 263, in load_marked_modules loaded, processed = load_module_graph(cr, graph, progressdict, report=report, skip_modules=loaded_modules, perform_checks=perform_checks) File "/opt/odoo/odoo-server/openerp/modules/loading.py", line 162, in load_module_graph registry.setup_models(cr) File "/opt/odoo/odoo-server/openerp/modules/registry.py", line 165, in setup_models model._setup_fields(cr, SUPERUSER_ID) File "/opt/odoo/odoo-server/openerp/api.py", line 204, in wrapper return old_api(self, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/api.py", line 297, in old_api result = method(recs, *args, **kwargs) File "/opt/odoo/odoo-server/openerp/models.py", line 2961, in _setup_fields field.setup(self.env) File "/opt/odoo/odoo-server/openerp/fields.py", line 360, in setup self._setup(env) File "/opt/odoo/odoo-server/openerp/fields.py", line 378, in _setup field = dep_model._fields[field_name] KeyError: 'section_id'

can Any one help me to resolve this?

Thank You.

Updated to full error message.

on 8/6/14, 5:13 AM
Jose M
On 8/6/14, 4:25 AM

You are missing de last part of the error trace.

Anyway, I was always getting a "section id" error everytime I try to install a module. Just restart de server, cancel installation and try again.

Hello Jose, I have updated the error message, as u told I restarted my odoo server several times and tried to insytall modules, But , no luck... :(

on 8/6/14, 5:15 AM
John Doe (jd)
On 8/6/14, 4:13 AM

To my perspective this error trace is not complete.

By the way I think I had your problems, but I didn't had it when installing OpenERP 7 from the .deb packaging.

hello John, I just updated the error code. This problem arises when a new database is created.

on 8/6/14, 5:13 AM

May me be mistaken, but I think I have read in some other question that this issue has been already solved and submitted to the repository.

John Doe (jd)
on 8/12/14, 3:32 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)


Asked: 8/6/14, 1:53 AM
Seen: 1067 times
Last updated: 3/16/15, 8:10 AM