Help

0

ERROR: Field does not exist

Avatar
Luis Reyes

I added a new field inside my custom model using the following steps:

Activate developer mode 
Go to Settings -> Technical -> Database Structure -> Models and search for your table name and add new fields in the table
Go to Settings -> Technical -> User Interface -> Views and search for your view name(tree, form, search or kanban etc) and add the fields in the view

However, I removed the custom field i created, and save it without removing first the UI I added in the corresponding view, and now it just return an error pasted below. I tried to find the xml that should cause the error but can't find it on the xml it should be located. 

ERROR: openerp.addons.base.ir.ir_ui_view: Field `x_second_address` does not exist

Any ideas how to solve this? Thanks


Avatar
Discard
2 Answers
0
Avatar
Niyas Raphy
Best Answer

Hi, 

You can find out the corresponding view by going into Settings -> Technical -> User Interface -> Views, and search for this field inside the View Architecture, ie, enter x_second_address in the search bar and make it search inside the Architecture, then you will get the corresponding view, then you can open the view and remove the field from it.

See this:  How can I retrieve all views using a particular field of a model?

Thanks

1 Comment
Avatar
Discard
Avatar
Luis Reyes
-

I thought about doing this but I cant access the UI because it already returning 500 Server Error. I think I fixed it already though by adding it in models.py and restarting the service. Thanks for your help!

0
Avatar
Luis Reyes
Best Answer

Nevermind haha. I just fixed it.

I just need to add the deleted field to the models.py and restart the service. 

Avatar
Discard