Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Error 500 after installing Odoo 8 on Turnkey Linux

By
Robert Chadwick
on 3/31/15, 3:48 PM 1,392 views

Just so you know, I'm very new to Odoo, and not that great in Linux.

I have a fresh install of Turnkey Linux, which I believe is based on Debian Wheezy. I ran these commands:


# wget -O - https://nightly.odoo.com/odoo.key | apt-key add -

# echo "deb http://nightly.odoo.com/8.0/nightly/deb/ ./" >> /etc/apt/sources.list

# apt-get update && apt-get install odoo


After, I go to http://127.0.0.1:8069. I get an error 500.


I couldn't find where Odoo was actually installed, but I found an error log. It mentioned something about not being able to access the database. I looked for a config file, and all I could find was openerp-server.conf, which only had about 5 lines in it (I don't have the exact file in front of me). I'm guessing somewhere there needs to be a config for how to access the database, but can't find it.


Is there a step-by-step instruction somewhere on how to install Odoo?


Thanks!

You have installed postgresql? Odoo it requires!

zbik
on 3/31/15, 4:34 PM

Are you installing in Ubuntu ?

Baiju
on 3/31/15, 11:39 PM
No, in Turnkey Linux.

I created a new VM, reinstalled Turnkey Linux, installed postgres, and then installed Odoo. I finally got past the 500 error, but once I try to set up the database, I get this:

Odoo


Odoo Server Error


Traceback (most recent call last):

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 530, in _handle_exception

    return super(JsonRequest, self)._handle_exception(exception)

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 567, in dispatch

    result = self._call_function(**self.params)

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 304, in _call_function

    return self.endpoint(*args, **kwargs)

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 796, in __call__

    return self.method(*args, **kw)

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 396, in response_wrap

    response = f(*args, **kw)

 File "/usr/lib/python2.7/dist-packages/openerp/addons/web/controllers/main.py", line 694, in create

    params['create_admin_pwd'])

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 872, in proxy_method

    result = dispatch_rpc(self.service_name, method, args)

 File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 114, in dispatch_rpc

    result = dispatch(method, params)

 File "/usr/lib/python2.7/dist-packages/openerp/service/db.py", line 73, in dispatch

    return fn(*params)

 File "/usr/lib/python2.7/dist-packages/openerp/service/db.py", line 90, in exp_create_database

    _create_empty_database(db_name)

 File "/usr/lib/python2.7/dist-packages/openerp/service/db.py", line 85, in _create_empty_database

    cr.execute("""CREATE DATABASE "%s" ENCODING 'unicode' TEMPLATE "%s" """ % (name, chosen_template))

 File "/usr/lib/python2.7/dist-packages/openerp/sql_db.py", line 158, in wrapper

    return f(self, *args, **kwargs)

 File "/usr/lib/python2.7/dist-packages/openerp/sql_db.py", line 234, in execute

    res = self._obj.execute(query, params)

DataError: new encoding (UTF8) is incompatible with the encoding of the template database (SQL_ASCII)

HINT:  Use the same encoding as in the template database, or use template0 as template.




On Tuesday, March 31, 2015 11:39 PM, Baiju KS <baijuks@hotmail.com> wrote:


Are you installing in Ubuntu ?
--
Baiju KS
Sent by Odoo S.A. using Odoo about Forum Post Error 500 after installing Odoo 8 on Turnkey Linux


Robert Chadwick
on 4/1/15, 12:06 AM

If you have not configured your OS to use UTF-8 as a default locale, you will encounter this error. dpkg-reconfigure locales .... after locale setting uninstall postgresql and install again.

zbik
on 4/1/15, 4:20 AM
Thanks for the response. I made a new VM with a new install of Turnkey Linux, ran dpkg-reconfigure locales, selected en-us utf-8, then installed postgresql, then Odoo. Still got the same error. Any ideas?




On Wednesday, April 1, 2015 4:20 AM, zbik <darek-krokus.com.pl@mail.odoo.com> wrote:


If you have not configured your OS to use UTF-8 as a default locale, you will encounter this error. dpkg-reconfigure locales .... after locale setting uninstall postgresql and install again.
--
zbik
Sent by Odoo S.A. using Odoo about Forum Post Error 500 after installing Odoo 8 on Turnkey Linux


Robert Chadwick
on 4/1/15, 10:27 AM

You install ubuntu package phppgadmin and verify database conections.

zbik
on 4/1/15, 2:00 PM

In openerp-server.conf you add line: log_level = info and verify error info in log /var/log/odoo/odoo-server.log

zbik
on 4/1/15, 2:06 PM
0
Mariusz Rajfura
On 4/1/15, 10:57 AM

Did you created user odoo in postgres template1?

This case generate "error 500" for first login too.

0
Robert Chadwick
On 3/31/15, 4:46 PM

I re-checked the link (That's what I used to install), but it didn't say anything about installing postgresql. I really don't know what I'm doing, but I typed:

apt-get install postgresql

After install, I typed:

service postgresql start

It said it started. I still get a 500 error.

So, is there a step-by-step tutorial on how to install Odoo?


Thanks!

0

zbik

--zbik--
5941
| 6 4 7
Lodz, Poland
--zbik--


zbik
On 3/31/15, 5:19 PM

Nightly command installs everything except python, postgresql and wkhtmltopdf (pdf reports). See documentation - Installing dependencies

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/31/15, 3:48 PM
Seen: 1392 times
Last updated: 4/1/15, 2:06 PM