Odoo Help

1

Database Field Name with Numbers

By
Evan Paradies
on 12/1/16, 9:37 AM 280 views

I am currently upgrading some old modules to V10 and have run into a problem.  Some of the field names begin with a number i.e. 855_test.  I have tried creating this field using the following and each produced an error:

855_test = fields.Many2one ('res.company')       #Syntax error

'855_test' = fields.Many2one ('res.company')      #cant assign to a literal

In the old API it was written like this and worked fine but obviously does not work with the new API:

_columns{

     '855_test': fields.many2one ('res.company'),

}

Does anyone know of a way to get these fields created in the V10 API?  I feel like its something simple I'm missing.


Thanks

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 12/1/16, 9:37 AM
Seen: 280 times
Last updated: 12/1/16, 3:28 PM