I have several types of products (boards, cabinets, doors) that we alternately manufacture or sell. I need to add a discriminator field to
product.template to specify what type of product we're dealing with.
There is already a field called
product.template, which has the possible values of product, consu, and service.
To me this field should probably be renamed to
inventory_method as it better represents the available choices and results, but that is another debate.
If I wanted to add some choices, I'd rename "Stockable Product" to "General Stocked Product" and add a few more options, like "Door", "Cabinet", etc.
For all these new types i'd like them to be treated as stockable.
Would you recommend creating a new field for this kind of disambiguation, or overriding the
type field? Would that be "safe", in that it would not effect other parts of the inventory system?
Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!
About This Community
|Asked: 3/29/13, 5:24 PM|
|Seen: 2203 times|
|Last updated: 3/16/15, 8:10 AM|