Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Crash after power failure. Can I fix this? [SOLVED]

By
Fabrice Candau
on 4/15/15, 9:17 PM 868 views

I had a power failure in my residence yesterday and as a result my server has been shutdown improperly.

Since when I try to access Odoo I get around 30 lines of error like this one;

Could not get content for /web/static/lib/cleditor/jquery.cleditor.css defined in bundle ‘web.assets_backend’.

I restarted Odoo many times, re installed all dependencies but I still have those errors and I cannot use Odoo at all.

I looks like something has been broken\, but I am not sure where to look and how to fix it.

Thank you for your help

@Fabrice,

I'd recommend checking your odoo server logs. What was your installation method for Odoo? What OS are you using?

I am running on Ubuntu 14.04 and installed Odoo from source using this script:

https://github.com/lukebranch/odoo-install-scripts/blob/master/odoo-saas4/ubuntu-14-04/odoo_install.sh

With this installation method my logs are in the following directory:

/var/log/odoo/odoo-server.log

What i'd recommend is start the odoo-server as you would normally, and then do the following at a command prompt:

sudo tail -f /var/log/odoo/odoo-server.log

Then try to access the Odoo URL and you should get a verbose output from your server-logs (assuming you have them switched on). I have my logs set to the following in the /etc/odoo-server.conf:

log_level = info

Once you've got a traceback after attempting to access the odoo instance in a browser i'd recommend copying the contents into a gist on github (or similar):

https://gist.github.com/

and posting back here with a link to the logs you have copied over.

This will help better troubleshoot things with you.

Luke Branch
on 4/15/15, 9:56 PM

Hello, Thank you for you help! Here is my log:

Fabrice Candau
on 4/15/15, 11:32 PM

Here is my log: https://gist.github.com/anonymous/14dfc0da40e92a31aab3 Sorry not sure how to embedded it in here. And here is the installation method I used: http://www.theopensourcerer.com/2014/09/how-to-install-openerp-odoo-8-on-ubuntu-server-14-04-lts/ EDIT: Not sure but it seems it would be coming from the Aero module I tried to installed before (but I got an error at this time, and it did not installed). But it is strange as I have had any problem after that but according to this link other people had exactly the same errors: https://github.com/jamotion/aeroo/issues/6 EDIT2: Problem solved. Indeed I needed to install aeroolib. I followed this and it fixed my problem: https://www.odoo.com/nl_NL/forum/help-1/question/8-0-how-can-i-install-the-official-aeroo-reports-alistek-for-odoo-version-8-solved-76044

Fabrice Candau
on 4/15/15, 11:33 PM
0
Lauen
On 4/16/15, 2:52 AM

@Fabrice,

line 28 indicate an ImportError: No module named aeroolib.

So you need to install aeroolib first.

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 4/15/15, 9:17 PM
Seen: 868 times
Last updated: 5/8/15, 10:21 AM