Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

-1

CPU usage of server becomes 100% while users are logging in to the syatem

By
shanil.K.N
on 9/25/14, 5:07 AM 1,262 views

I am using

Ubuntu 12.04 LTS server

OpenERP 7

and the service is hosted in cloud environment(Rackspace).

 

When a user is trying to loggin to the system the server CPU usage becomes 100%(postgres process), what is the reason for this issue ?.

 

Hi Shanil.Found solution,let me know if you found solution.Im also facing these issues.

Saravanan Sakthivel
on 9/25/14, 6:04 AM
1
Harsh Dhaduk
On 12/18/14, 5:08 AM

Hello Shanil,

I faced same problem like you and i overcome using following points. i hope this thing help to you.

Your Server Memory is full you can use following steps.

*First ->* check system disk space using *$df -h* command after it'll show %memory usage.

*Second ->* Then find *.xsession-errors* files using /locate/ command.

*$locate .xsession-errors* (if you have two linux user then it will dispaly 4 file each linux user have 2 files)

 

*Third ->* Check each size using following command

*$du -h /home/odoo/.xsession-errors* and *.xsession-errors.old files*

If file is in MB or in GB then flush that file don't remove it, using following command

*$echo "" > .xsession-error*

*And Last Step*

if you have any backup files, extra files ,temparory files like pdf,csv file odt etc file in /tmp folder bofore remove keep backup of it and then remove.

in sort /*remove un-usefull files from server.*/

After check system space using *$df -h* command. If server space is not descrese then you need extra space.

0
shanil.K.N
On 9/26/14, 1:05 AM

Thank You very much for the fast response.

I could not locate the ".Xsession-errors" file in my OS.

I am using Ubuntu 12,04 LTS(Server),could you please help me to find the ".Xsession" files.

command for find .xsession-errors is "locate .xsession-errors" in your terminal window.

LIfe
on 9/26/14, 2:31 AM

I have already tried this command,but the system shows an error message "No such file or directory". I am using Ubuntu server without GUI.

shanil.K.N
on 9/26/14, 3:12 AM

can you please show me that command?

LIfe
on 9/26/14, 3:51 AM

root@ERP1:~# locate .xsession-errors root@ERP1:~#

shanil.K.N
on 9/26/14, 4:40 AM

root@ERP1:~# locate .xsession-errors root@ERP1:~# I have tried the above command.

shanil.K.N
on 9/26/14, 4:42 AM
0
LIfe
On 9/25/14, 6:49 AM

hello shanil and my dear frnd harsh

i have solution for this you have to flush not deletthe .xsesson-errors file using the below given command

step 1: find the .xsesson-error file

step 2: flush that file command is $echo "" > .xsession-errors

step 3 : finaly njoy!!!!

 

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 9/25/14, 5:07 AM
Seen: 1262 times
Last updated: 3/16/15, 8:10 AM