Odoo Help

0

0
6 Answers
1
Bernard
1/18/17, 5:31 AM

Please check your ir_cron actions for "scheduled actions" that have  very small interval_time like 1 minute interval. It is likely that the next run is starting before the previous one is finished (LOCKED FOR UPDATE). This happens in scheduled actions like fetching mail from your mail server which may take longer than 1 or 2 minutes due to connection issues or alot of emails to download. 

0
Avatar

Zbik

--Zbik--
7359
| 7 5 9
Łódź, Poland
--Zbik--


Zbik
3/10/15, 3:29 AM

You verify how many openerp server instances have run.

>ps aux | grep oepenrp

or, you set in openerp-server.conf

max_cron_threads = 1

This appears to be because two cron threads run the same command.

2 Comments
Mathias Colpaert
5/29/15, 9:59 AM

I only have 1 server instance running. max_cron_threads is set to 2, but if this is the bug, why does this option even exist? Should I always put max_cron_threads = 1, and why?

Zbik
5/29/15, 12:35 PM

If the whole system works properly, settings max_cron_threads = 2 is good.

Ask a Question
Keep Informed
3 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now