Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Configuring email: Google works. Office 365 doesn't. SMTPDataError: 550 5.7.60 SMTP; Client does not have permissions to send as this sender

By
Hamid Darabi
on 11/27/15, 2:00 PM 5,903 views

I am trying to configure the outgoing mail server. I tried google and it works fine but with outlook.office365.com it doesn’t work. The connection test is successful but when I send a message to a client, in mail setting I see that it was failed and I get this error message:

Mail Delivery Failed

Mail delivery failed via SMTP server 'smtp.office365.com'.

SMTPDataError: 550

5.7.60 SMTP; Client does not have permissions to send as this sender

I tried None, TLS and SSL, different port numbers (25, 465, 587, and even 993 and 995) and different URLs (outlook.office365.com and smtp.office365.com) but no luck. I read somewhere that I need to create a new connector on my exchange mail flow but I don't know what is the exact required configuration since I'm using Odoo Live.

I found this tutorial and configured the relay required for communication with smtp server. Guess what? new error message. smtp auth extension not supported by server

Analystik, Hamid Darabi
on 11/27/15, 5:12 PM

https://technet.microsoft.com/en-us/library/dn554323(v=exchg.150).aspx

Analystik, Hamid Darabi
on 11/27/15, 5:14 PM
0
Ariel Rodgers
On 11/30/16, 12:12 PM

I have had this exact same error on ODOO 9.0 since my company switched our email servers to Office 365.

We did the setup as per all above instructions and kept getting the 5.7.60 SMTP; Client does not have permissions to send as this sender error.

Tried setting up the exchange connector and direct relay to no avail.  On investigation it seems that the default mail address configured in ODOO works fine if it it the actual sender address.  When i looked at the queued failed emails i noticed that everyone of them is using an actual individual users email address as the source.  I tried in office 365 to grant send on behalf permissions to my default mail account but still got these errors.


I have now used a free SENDGRID SMTP Relay account (Sendgrid.com) for our outbound ODOO Emails and everything works correctly - Not a resolution i know but a workaround that allows us to keep our correct email address and not use a GMAIL.  Thought i would share.


0
Yannick Belot
On 1/19/16, 7:46 PM

I have the same problem Hamid! How did you solve it? Did you change your SMTP email provider?

No, I didn't. I directly contacted Odoo support and a couple of official partners. Seems like no one has done this before which I can't get over.

Analystik, Hamid Darabi
on 1/20/16, 9:46 AM

This is how Odoo support responded: You need to configure office365 to allow to send messages with a different account with the one set on office365, by default it is disallowed. Maybe you could contact your email service provider to more information.

Analystik, Hamid Darabi
on 1/20/16, 9:48 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 11/27/15, 2:00 PM
Seen: 5903 times
Last updated: 11/30/16, 12:12 PM