Odoo Help


Change currency symbol on invoice

on 9/8/16, 10:09 AM 1,365 views

I need to remove the currency symbol on the pdf invoice (print action). Right now it's $.

The symbol is gone from the invoice page when I changed the default currency. But it still appear on the pdf. 

I changed the default currency, removed USD, look in the technical features, and went through many setting to look for it to no avail.


On 9/9/16, 10:49 AM

Ok I found how to do it.

You need to install accounting module, activate multiple currency and then go to sales - setting - pricelist.

Add the desirable currency.

From there on, currency can be changed on the quotation page.

Divyang Jariwala
On 9/9/16, 12:32 AM

Hi Noris,

To remove currency symbol remove

t-field-options='{"widget": "monetary", "display_currency": "o.currency_id"}'

And now about default currency you are changing but its not affecting in invoice report.

that is just because invoice report is loading from "Attachment"

for that do following steps:

Go to Setting > Technical > Reports > Reports 

Open Invoice report.

And Unchecked "Reload from Attachment" if it is Checked.

I hope its helps you.

Hi Divyang, thanks for replying.

I am on Odoo saas. Where can I change the t-field-options='{"widget": "monetary", "display_currency": "o.currency_id"}' ?

on 9/9/16, 10:16 AM
On 3/15/18, 6:01 AM

Hi Noris, the simple fast solution is to modify it directly on the DB, go to your DB ==>res_currency and change it manually, refresh you application, and everything is gonna be well.

Very bad advise. Do not manipulate the database directly.

Ermin Trevisan
on 3/15/18, 9:15 AM

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.


Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)


Asked: 9/8/16, 10:09 AM
Seen: 1365 times
Last updated: 3/15/18, 6:01 AM