cannot access the localhost:8069 | Odoo

cannot access the localhost:8069

==== When i open localhsot:8069 then this error is appear i am new in erp help me====

OpenERP Server Error

Client Traceback (most recent call last):
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\http.py", line 203, in dispatch
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\controllers\main.py", line 747, in get_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\controllers\main.py", line 89, in db_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 31, in proxy_method
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 104, in send


Server Traceback (most recent call last):
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\openerp\addons\web\session.py", line 90, in send
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\netsvc.py", line 293, in dispatch_rpc
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\service\web_services.py", line 122, in dispatch
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\service\web_services.py", line 359, in exp_list
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 484, in cursor
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 182, in __init__
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 377, in _locked
  File "C:\Program Files (x86)\OpenERP 7.0-20130319-002358\Server\server\.\openerp\sql_db.py", line 440, in borrow
  File "psycopg2\__init__.pyc", line 178, in connect
OperationalError: could not connect to server: Connection refused (0x0000274D/10061)
    Is the server running on host "localhost" (::1) and accepting
    TCP/IP connections on port 5432?
received invalid response to SSL negotiation: -
Mohsin khan
Mohsin khan
11
| 3 1 2
Asked on 3/20/13, 12:43 PM
0
vote
7032 Views

How did you make the installation? Did you first tested it without SSL?

ton123
on 3/20/13, 1:35 PM

This is a little few information to go on. I assume you installed OpenERP 7 under Windows with the all-in-one client? Can you log in to the postgresql database using the pgadmin III client?

Try if you can access your server directory through pgadmin, you can also backup any of your existing databases here. Were you able to ever connect to OpenERP on localhost, and did it change recently - or were you never able to set it up properly?

Laurens
on 3/20/13, 1:41 PM

Worst case scenario you can also uninstall OpenERP server and the postgresql server. (+ any additional dependencies if you installed them with stacklauncher after the initial configuaration) Then open a regedit and search for all registry keys from OpenERP and postgresql, delete all of them. Reboot your system and reinstall using the all-in-one launcher, leave all of the settings/options on their default values. (e.g. "localhost" and the port 8069) You should get an out-of-the-box working OpenERP installation for localhost if you just install the necessities and don't change the default values

Laurens
on 3/20/13, 1:43 PM

i have the same problem but when i m trying to connect the postgres through pgadmin when it is giving error :recieved invalid response to ssl negotition

katty
on 11/19/14, 8:20 AM

if you are working under Windows go to services and restart the Openerp server or the Postgres server. These servers are set up to start automatically but sometimes they fail. The options you may have are either to Restart or Stop/Start.

omar bajunaid
omar bajunaid
120
| 4 3 5
Answered On 3/21/13, 11:01 AM
0
vote

Actually,

If postgresql is running, the problem could come from a problem with IPV6 and IPV4 protocols. The (::1) should be bind to the localhost in your lmhost. Maybe you could try to bind it to your IP. I already had this issue with other systems conecting to postgresql

Mind And Go
Mind And Go
435
| 5 2 4
Answered On 3/21/13, 12:37 AM
0
vote

From your traceback, the problem is that OpenERP is not able to connect to Postgres database:

could not connect to server: Connection refused (0x0000274D/10061)
Is the server running on host "localhost" (::1) and accepting
TCP/IP connections on port 5432?

Check if Postgres is running. If you think so and still have the problem, try connecting using a GUI tool such as pgAdmin.

Daniel Reis
Daniel Reis
3067
| 6 7 9
Answered On 3/20/13, 5:58 PM
0
vote

Your answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice.

Ask a Question

About This Forum

This community is for professionals and enthusiasts of our products and services.


Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/20/13, 12:43 PM
Seen: 7032 times
Last updated: 11/19/14, 8:20 AM