Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Browse always block live chat because it had mixed and insecure content

By
lam nguyen
on 10/17/14, 7:04 AM 1,480 views

Dear All,

I was setup odoo run with nginx proxy using ssl and enable live chat support, but browse always block live chat because it had mixed and insecure content from live chat module. Could you give me a advice to secure content of live chat module.

Thanks.

Lam

 

Hi All,
I had resolved it. Just go to : Setting/Parameters/System Parameters/web.base.url
Change it to https://xxxxxx.
It's all.
Thanks

1

Yenthe

--Yenthe--
6716
| 7 7 8
Turnhout, Belgium
--Yenthe--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe
On 9/1/15, 10:58 AM

Hi guys,

Since there hasn't been any solution posted yet.
The web.base.url is by default reset when you would reboot your Odoo, that is default behaviour. There is a simple way to prevent this. Create a new parameter with the name 'web.base.url.freeze' and set the value to 'True'. This will prevent the web.base.url from being modified by Odoo and the web.base.url will keep working on HTTPS.

Yenthe

0
leonardo chianea
On 9/1/15, 10:52 AM


there is a very easy fix for this.

Add a new parameter 'web.base.url.freeze' and set the value to 'True'. This will prevent Odoo from updating your web.base.url.


credit: Yenthe666 https://github.com/Yenthe666 

0
Marek Matej
On 5/18/15, 12:11 PM

Hi, I have similar problem with odoo after I switch to https. Indeed the web.base.url key needs to be changed, but anytime I change it to https it is back to http after I logout and login again. Any suggestion how to solve this?


the same for me ... anytime I change it to https it is back to http after I logout and login again.

leonardo chianea
on 8/29/15, 2:11 AM
0
Craig Barnes
On 10/17/14, 9:29 AM

Do you have `proxy_mode = True` in your config?

Dear Craig Barnes, Thank for your repply. Yes I have `proxy_mode = True` in my config, I using nginx upstream, proxypass.

lam nguyen
on 10/17/14, 7:53 PM

I have a similar setup, but had not tested the online support module. Looking at it now I see that I have the same issue.

Looks like the service is not checking for the proxy X-Forwarded-Proto header value. Have you checked to see if this issue has been reported at github?

OpusVL, Craig Barnes
on 10/21/14, 6:11 AM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

2 follower(s)

Stats

Asked: 10/17/14, 7:04 AM
Seen: 1480 times
Last updated: 9/1/15, 10:58 AM