Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Barcode Scanner works only partially with POS

By
Kobold Japan K.K.
on 7/9/15, 8:48 PM 1,048 views

Dear all,

it´s my first post in this community. Thanks for letting me in.

I´d like to ask a question regarding odoo POS and using a barcode scanner.

I created several products within the POS. The related barcodes have a lenght of six digits (e.x. 100182) which are set as an attibute within the POS. The barcode reader is an ordinary usb device. I created a dummy product with an 13 digit barcode for testing purpose and scanning the code went well. I tried same with the six digit one but odoo couldn´t recognice it:

"Unknown Barcode 100182. The Point of Sales could not find any product, client, employee or action associated with the scanned barcode.

I suspect that I have to change the Barcode Nomenclatures in order to have my own barcode recognized be the POS. If my assumption is correct, how can I tell the POS what to look for?

I appologize for my question in advance but I´m new to odoo and couldn´t find an appropriate answer to my problem.

With best regards,

Mike

0

Fabrice Henrion (fhe)

--Fabrice Henrion (fhe)--
5823
| 7 7 8
San Francisco, United States
--Fabrice Henrion (fhe)--

Director Odoo USA

Fabrice Henrion (fhe)
On 7/9/15, 9:51 PM

The behavior of the barcode reader for the POS was not great in v8 and before. It has been improved after v8. You might want to read the following post to understand how to configure barcodes according to which version you are using:
https://www.odoo.com/groups/community-59/community-11131624?mode=thread&date_begin=&date_end= 

1
Kobold Japan K.K.
On 7/16/15, 9:02 PM

Fabrice,

thanks for your help.

Figured it out and it works.

Just got another issue: If I use the Barcode scanner, the products are now displayed at the POS - but without any price. If I just select the products direcly from the POS it works normal, only at times I use the scanner it doesn´t. Any hint on this problem?


Best,

Mike

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 7/9/15, 8:48 PM
Seen: 1048 times
Last updated: 7/16/15, 9:42 PM