Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

1

Backend custom widget not display content?

By
Jo
on 12/30/15, 1:39 PM 673 views

Hi all,

Here i want to show a table in form view, here is what i am tried.

views/templates.xml

<openerp>
 <data>
 <template id="assets_backend" name="backoffice_assets" inherit_id="web.assets_backend">
 <xpath expr="." position="inside">
 <script type="text/javascript" src="/backoffice/static/src/js/back.js"></script>
 </xpath>
 </template>
 </data>
</openerp>

static/src/js/back.js

openerp.backoffice = function(instance) {
     instance.backoffice.Matrix = instance.web.form.FormWidget.extend(instance.web.form.ReinitializeWidgetMixin, {
         init: function() {
         this._super.apply(this, arguments);
         },
     }); 
 instance.web.form.custom_widgets.add('matrix', 'instance.backoffice.Matrix');
};

static/src/xml/back.xml

<templates id="template" xml:space="preserve">
 <t t-name="Matrix">
 <div>
 <b>Hai this is test</b>
 </div>
 </t>
</templates>

views/custom_view.xml

<widget type="matrix"></widget>

But not working, please anyone helpme....

Thanks in advance...

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 12/30/15, 1:39 PM
Seen: 673 times
Last updated: 7/20/16, 10:04 PM