Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

access denied when trying to make a backup on openerp7

By
Guy Wart
on 3/21/13, 11:30 AM 1,850 views

Hello,

On openerp 7 on debian, I have several database installed. One of these is impossible to backup: I have this message popup: Backup of the Database Access Denied

With the other databases on the same server, it is working well. I try to change the password but it is the same result.

Thank you

The database is created with the openerp interface, or manually from console?

Agile Business Group sagl, Franco Tampieri
on 3/21/13, 11:32 AM

The database was imported from vers6, I thought manually from console

Guy Wart
on 3/21/13, 12:28 PM

Do you have user the --no-owner option in pgdump? Probably that is the problem

Agile Business Group sagl, Franco Tampieri
on 3/22/13, 11:25 PM
1
Guy Wart
On 3/24/13, 3:38 PM

At the end, I find the solution: it is a problem of ownership of two tables that we create for backup: the owner was 'postgres' and not 'openerp'; when I correct it, it was solved So thank you, User 12396, you were right, it was an owner problem.

Hi, for information openerp doesn't work with postgres role, the reason is a security issue. Bye

Cyril Gaspard (GEM)
on 3/24/13, 4:07 PM

I'm glad that my suggestion help you to solve your problem.

Agile Business Group sagl, Franco Tampieri
on 3/25/13, 5:51 AM

I can't backup databases either. How did you fix this?

Granite City Performance, Don Hoeschen
on 7/20/13, 9:55 PM

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

1 follower(s)

Stats

Asked: 3/21/13, 11:30 AM
Seen: 1850 times
Last updated: 3/16/15, 8:10 AM