Odoo Help

Welcome!

This community is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

0

Access Denied (Document type: Partner, Operation: read error)

By
ali
on 5/25/13, 4:28 AM 16,978 views

hi,

i have facing problem in Portal->Billing->Quotation by User(portal group), when user click on any quotation to view than the following error popup.

Access Denied The requested operation cannot be completed due to security restrictions. Please contact your system administrator. (Document type: Partner, Operation: read)

Same problem here, any update?

dirtyHandsPHP
on 9/1/14, 9:40 AM

I am having the same problem. Any idea?

FBA, Fred Blauer
on 9/6/13, 5:44 PM
0

Sudhir Arya (SA)

--Sudhir Arya (SA)--
10150
| 6 8 8
Ahmedabad, India
--Sudhir Arya (SA)--

Working as an OpenERP/Odoo developer and a Team Leader 

Top 5 Odoo contributor On Stackoverflow

LinkedIn

Blog

Stackoverflow

Sudhir Arya (SA)
On 1/2/15, 5:35 PM

I am agree with Malte Helmhold.

You are right. The portal and public user have some limited rights on some of the objects. So if one of the group has been assigned to user except admin, you will have access rights error/message.

3
Narayanamurthy
On 9/16/14, 10:08 AM

Hi,

1. That error warning might be from the permission given to "res.partner" object for the perticular user group,

or

2. Check the record rule related to res.users,

settings->security->record rules

3
Malte Helmhold
On 9/16/14, 7:00 AM

I finally found out! it's a conflict of user permissions Access Levels. 

You have to experiment with the settings under User -> Permissions -> Other!!! 

A portal user has limited rights, so uncheck portal and uncheck public and just for debugging try to 

uncheck everything for a moment. Somehow this User/Survey is something I can't uncheck. But anyway, it's working now

and finally the user I had headache with can do what they want and they're real internal company users and have more accss rights

this works for me, thanks Malte

August Doo
on 6/30/15, 5:33 AM

this works for me, thanks Malte

August Doo
on 6/30/15, 5:33 AM
0
Thomas H.
On 9/6/16, 1:56 PM

Solved that with inactivating the user via settings / users / individual user - there deactivate the little box behind "active".

After that follow the description here to reactivate the user: https://www.odoo.com/forum/help-1/question/inactive-user-reactivation-32211

0
E.R. Spada II
On 9/2/14, 12:39 AM

Yes, on the user/access rights, Under Other,  uncheck Contact Creation. This selection is actually reverse, unless Portal User.

 

-1
Qamar Soft
On 12/31/14, 6:55 AM

try reinstall the base module using :

odoo.py -d YourDB -i base --without-demo=base

 

Your Answer

Please try to give a substantial answer. If you wanted to comment on the question or answer, just use the commenting tool. Please remember that you can always revise your answers - no need to answer the same question twice. Also, please don't forget to vote - it really helps to select the best questions and answers!

About This Community

This community is for professionals and enthusiasts of our products and services. Read Guidelines

Question tools

5 follower(s)

Stats

Asked: 5/25/13, 4:28 AM
Seen: 16978 times
Last updated: 9/6/16, 1:56 PM