Ayuda

0

odoo 11 CE: google calendar synchronisation connection error 400

Hello,

I have the same problem with the synchronization of google calendar as Hannes Hörting even I'm using our public IP for creating the API credentials. The router is forwarding the port 8069. Everything is working fine and It is possible to connect from outside to our local odoo server.

The first try was with the following URI: http://121.xxx.xxx.xxx:8069/google_account/authentication

For the second try I configured DNS of a domain name I had left to our server. After 24 hours the DNS was working and I used the following URI for the API credentials: http://ourdomain.ch:8069/google_account/authentication

After pressing the synchro button I get allways the same error:

400. That’s an error.
Error: invalid_request
device_id and device_name are required for private IP: http://10.0.0.5:8069/google_account/authentication

Why is still used my local IP? What is wrong and where should I change this settings?

Thanks for help.

Stefan

 

Avatar
Descartar
2 Respuestas
0
Best Answer

Thank you DHA Medic. As written in my question I already created the credentials also with our public domain.

But I don't understand, why error 400 shows still the local IP 10.0.0.5. It seems some setting in odoo is wrong. I have no other explanation...

Avatar
Descartar
0
Avatar
DHA Medic
Best Answer

if you are a developer, you can use "localhost"

if you publish this site, you must use your domain - your_site.com

Avatar
Descartar