Sources de données

Lorsque vous insérez une liste ou un graphique depuis une vue liste ou graphique Odoo dans une feuille de calcul Odoo, ou insérez un tableau croisé dynamique référençant des données Odoo depuis une vue croisée Odoo ou directement depuis une feuille de calcul, la feuille de calcul est automatiquement connectée aux données sous-jacentes grâce à une « source de données » unique.

Cette connexion garantit que les données de la feuille de calcul sont mises à jour lorsque les données correspondantes de votre base de données changent, et vous permet d”accéder aux données sous-jacentes.

Note

  • Les données d’une liste, d’un tableau croisé dynamique ou d’un graphique lié à un modèle Odoo sont actualisées à chaque ouverture de la feuille de calcul ou rechargement de la page du navigateur. Il est également possible d’actualiser manuellement les données en cliquant sur Données ‣ Actualiser toutes les données dans la barre de menu.

  • Insérer un tableau croisé dynamique depuis une plage de données crée également une source de données qui connecte le tableau croisé dynamique à la plage de feuille de calcul sous-jacente.

Chaque source de données est identifiée par un ID unique, chaque type de source (c’est-à-dire liste, tableau croisé dynamique ou graphique) étant numéroté séparément, et chaque nouvelle liste, tableau croisé dynamique ou graphique numéroté de manière séquentielle, par exemple Liste #1, Liste #2, Croisé #1, etc.

Les propriétés d’une source de données sont accessibles via le menu Données, où elles sont regroupées par type de source, puis listées par ordre croissant d’identifiant de source. Le nom de la source de données est affiché, par exemple (#1) Sales Analysis by Product.

Cliquer sur une source de données ouvre les propriétés associées dans un panneau à droite de la feuille de calcul.

Note

La suppression d’une liste ou d’un tableau croisé dynamique inséré, ou la suppression de la feuille dans laquelle ils ont été insérés, ne supprime pas la source de données sous-jacente ; cela peut être fait via les propriétés de la source de données. Les sources de données inutilisées provenant de listes ou de tableaux croisés dynamiques insérés peuvent également être supprimées via la fonctionnalité Nettoyage des données. La suppression d’un graphique inséré supprime sa source de données sous-jacente.

Astuce

  • Le panneau des propriétés peut également être ouvert en faisant un clic droit sur n’importe quelle cellule d’une liste ou d’un tableau croisé dynamique insérés, puis en cliquant sur Voir les propriétés de la liste ou Voir les propriétés du tableau croisé dynamique, ou en cliquant sur l’icône (menu) en haut à droite d’un graphique inséré, puis en cliquant sur Modifier.

  • Une fois les propriétés d’une source de données spécifique ouvertes, elles restent ouvertes même lors de la navigation entre les onglets de la feuille de calcul. Pour fermer le panneau des propriétés, cliquer sur l’icône (fermer) en haut à droite du panneau.

  • Pour réduire le panneau des propriétés, cliquer sur l’icône (double chevron) en haut du panneau.

  • Pour épingler le panneau des propriétés et permettre à un autre panneau, tel que le panneau des filtres globaux, de s’ouvrir à côté, cliquer sur Affichage ‣ Épingler le panneau latéral dans la barre de menus. Pour désépingler un panneau, cliquer sur l’icône (épingle) en haut à droite du panneau.

Identifier et supprimer les sources de données inutilisées

Pour identifier et supprimer les sources de données inutilisées, c’est-à-dire les sources de données qui sont toujours connectées à la feuille de calcul mais dont les données ont été supprimées, suivre ces étapes :

  1. Cliquer sur Données ‣ Nettoyage des données ‣ Supprimer les sources de données inutilisées dans la barre de menus. Le panneau Sources de données inutilisées s’ouvre à droite de la feuille de calcul. Les tableaux croisés dynamiques inutilisés et les listes inutilisées sont affichés dans leurs sections respectives.

  2. Le cas échéant, désélectionner les sources de données qui ne doivent pas être supprimées, puis cliquer sur Supprimer les éléments sélectionnés.

Accéder aux données sous-jacentes

Les données sous-jacentes d’une liste, d’un tableau croisé dynamique ou d’un graphique inséré peuvent être consultées à tout moment. Pour afficher :

  • un enregistrement individuel d’une liste insérée, faire un clic droit sur n’importe quelle cellule de la ligne concernée, puis sélectionner Voir l’enregistrement

  • une liste d’enregistrements référencés par une cellule individuelle d’un tableau croisé dynamique inséré, faire un clic droit sur la cellule, puis sélectionner Voir les enregistrements

  • une liste d’enregistrements représentés par un point de données d’un graphique inséré, cliquer sur le point de données.

Astuce

Utiliser le bouton central de la souris ou Ctrl + clic gauche (Microsoft/Linux), ou Command + clic gauche (Mac OS) pour ouvrir les résultats dans un nouvel onglet du navigateur.

Pour revenir à la feuille de calcul après avoir consulté les données sous-jacentes, cliquer sur le nom de la feuille de calcul dans le fil d’Ariane en haut de la page.