Assistenza

2

Unable to attach files in Odoo when using HTTPS via nginx

Avatar
Patrick Miller

Been having an issue and finally narrowed it down, but can't find a solution.


If I setup nginx to redirect to HTTPS, everything works great, SSL connection and all, except when writing messages in Odoo, our staff can't attach files. It gets stuck on "uploading" (blue bar over the file icon). There's no useful output in the log, even on the most verbose debug level. 


As a workaround, I've disabled SSL, but I'd like to turn it back on. Suggestions? Running v9.0c.

2 Commenti
Avatar
Abbandona
Avatar
Patrick Miller
-

Hey Onnet, I checked and ours is currently set to 300M. Shouldn't be an issue.

Avatar
Ermin Trevisan
-

Just a hint to everyone reading this thread: such observation can have different causes, so you have to check your browser's console message first. Depending on the cause, you can find a solution, such as some listed here. There maybe others.

4 Risposte
6
Avatar
Michell Stuttgart
Migliore risposta

I find this same problem and using Chrome developer tool, I find that X-Frame-Options is set like DENY.

To fix it, I edit the file  /etc/nginx/snippets/ssl.conf 

In this file, comment this line:

add_header X-Frame-Options DENY;

and add this line:

add_header X-Frame-Options SAMEORIGIN;
and restart nginx
sudo service nginx restart
Reload the Odoo page (F5) and try attach again. Must be work.

Referencies:
https://serverfault.com/a/801680
3 Commenti
Avatar
Abbandona
Avatar
Patrick Miller
-

You're a HERO! This worked. Thank you so much. Really appreciate it.

Avatar
José L. S. Alaguna
-

Yes, it works!!!

Avatar
ibrahim halouane
-

There is no `ssl.conf` file for me!

2
Migliore risposta

We had similar issue in our setup running nginx as reverse proxy. The solution is simple. Just increase the upload file size limit for nginx by adding the line below to nginx.conf file

http {
    client_max_body_size 50M;
    //other lines...
}


3 Commenti
Avatar
Abbandona
Avatar
Patrick Miller
-

Hey Onnet, I checked and ours is currently set to 300M. Shouldn't be an issue.

Avatar
Ned
-

This worked perfectly for us. Thanks Onnet

Avatar
José L. S. Alaguna
-

It didn't work for me, i tried with 50M and it didn't work.