Ajuda

0

Avoid message "You have been assigned to" for new invoices

Salespeople assigned to invoices are notified each time one is created.

Can I stop this? 

5Comentários
Avatar
Descartar
Avatar
Shivoham
-

Thanks for your answer, Shivoham. 

The forum thread you send me is quite old and refers to version 8. My DB is in version 13.
It does not exactly relate to my question either.
I need the salespeople not to receive a notification for every invoice created. When an invoice is created (before being posted) they receive a message that says: "You have been assigned to invoice... ".
There are a lot of invoices so they receive too much useless notifications. 

Dit you get a solution for this yet?
I created an automated action that removes followers from the invoice (based on a condition on the contact so we can select who is allowed to follow invoices), but the mail gets send before the automated action removes the followers...
You should be able to control this in the Subtypes in Technical Settings (v15) but this seems to be hard coded behavior.
I am hoping you found a solution, if so please share.

Avatar
Jaideep
-

@Toon van der Ploeg, you may need to create the automated action on the followers model so they are never added to an invoice.

https://www.odoo.com/forum/help-1/automated-action-to-remove-vendor-as-default-follower-from-po-v14-181175

@Jaideep, Thanks for the suggestion. I already tried that. Both on the Invoice model and on the Followers model. In both cases the mail still gets send. First mail "you have been assigned to draft invoice..." and the second when the invoice is confirmed simply always cc's that mail to the Salesperson.
I think @Canditroot provided the best approach: overriding the method based on a condition. But I would need the steps to do that in odoo.sh. Condition in my case could be a Boolean on the partner model "cc in customer invoices".

2Respostas
1
Melhor Resposta

You may override the method '_message_auto_subscribe_notify' and stop the notification message based on condition

Thanks & Regards,



CandidRoot Solutions Pvt. Ltd.

Mobile: (+91) 8849036209
Email: info@candidroot.com
Skype: live:candidroot
Web: https://www.candidroot.com
Address: 1229-1230, Iconic Shyamal, Near Shyamal Cross Road, Ahmedabad, Gujarat 380015
    

Avatar
Descartar
0
Avatar
Jaideep
Melhor Resposta

You might need to deactivate the Qweb View: message_user_assigned

Do check the post below, though it refers to deactivating user assigned notifications on an SO it might help.

https://www.odoo.com/forum/help-1/prevent-the-message-from-automatically-going-out-when-salesperson-is-assigned-to-an-so-and-its-confirmed-190501

4Comentários
Avatar
Descartar

That is certainly helpful, but won't this disable all assignment messages?
What if we simply do not want Salespersons to be assigned to Customer Invoices? Many organizations have an AP department for that.

I could not edit my previous comment. But I tested disabling the view, still email gets sent out "you have been assigned to draft invoice..."

Avatar
Jaideep
-

Sorry, I hadn't tested this myself had forwarded the post as is. Also, would you know if you were creating an Invoice from an existing SO (SO that was created prior to deactivating the view)?

Also, if your case is to exclude a person or group you could probably create an automated action

A few posts on how that could be helpful
https://www.odoo.com/forum/help-1/how-can-i-remove-all-followers-via-an-automated-action-189762
https://www.odoo.com/forum/help-1/automated-action-to-remove-a-follower-205944
https://www.odoo.com/forum/help-1/automated-action-to-remove-vendor-as-default-follower-from-po-v14-181175

Jaidepp: Thanks for your today's answer. I will study it carefully