Community: CMS / eCommerce Experts mailing list archives


Re: How do I refresh routes when building a module?

Komit Consulting, CÔNG TY TNHH KOMIT, Jean-Charles Drubay
- 2014年11月17日 20时52分39秒
I have been facing the same issue yesterday on the home page of a website (luckily it is a personal website), even after:
  • restarting the server and upgrading my module
  • restarting the server and upgrading base
  • restarting the server with update=all
What is even more crazy is that last time it happened (10 days ago), I backedup/restore the faulty production database to my local and everything work nicely on my local. At that time, I could restored the situation by doing a "restart + update=all".

Both times, I have added some logs in the controller of my home page and I see that when having the issue the logs are not printed (but last time they were printed after issue was fixed).

At this time, I suspect an inheritance conflict, here is how my controller is created:

from openerp.addons.web.controllers import main 

class mycontroller(main.Home):

    @http.route('/', auth='public', website=True)
    def index(self):

Maybe, I should try:
from import main 


Jean-Charles DRUBAY
Operations Manager
Mobile: +84-(0)909-64-34-69
Office: +84 (0)862-737-605
Skype: jc.drubay
trobz - Open Source Solutions for the Enterprise
Address: 4th floor, 47/2/57 Bui Dinh Tuy st. , Binh Thanh dist., HCMC

On Tue, Nov 18, 2014 at 6:26 AM, Darrel Grant <> wrote:

I'm working a module and making changes to routes and responses in a
web controller, but they aren't getting picked up for some reason.

I've tried everything I can think of: refreshing the module list,
uninstalling, reinstalling, updating the module and still when I load
the routes, I either get a 404 (new routes not being registered), or
the old content (old route not showing updated content).

I've tried all the steps I know in various orders and can't get my
changes to show. What do I need to do?


Post to: