Help

4

Winter/Summer time change problem / recurrying events - any news ?

Avatar
Dr Obx

Guys,

I already asked but nobody responded my question.

If I setting up a recurring event and within the period of  this event time is changing from Winter/Summer or Summer/Winter

the time of the event is changing as well.

But it shouldn't because regardless of the change it should still point to the same time. Some people won't understand it and say "It's ok!" NO!!! it's not OK. This problem must be fixed immediately.

For example, if I setting up a meeting at 9:00 because of this bug, it will change meeting time to 10:00. Maybe I'm wrong, maybe time will change when the change day will come and it will be back changed to 9:00 (don't think so).

Same with daily alarm, if I setting up alarm to wake up on time for example at 6:00 am, if then will be time changed .... will it wake me up at 5:00 ? NO!!!

It will still wake me up at 6:00 am (time will be changed +/- one hour).

If anyone meet this problem and solved it ..... please share with me how to do it.

I already asked Odoo help/support but apparently they don't care if you don't have a contract with them.

They won't fix their own errors/mistakes :)

So ......

Do anyone know how to fix this issue ? (My knowledge is still not good enough to do it myself :()

Any fixes available ?

5 注释
头像
丢弃
Avatar
Ray Carnes
-

If you have a 9am meeting, then go through a time change, it SHOULD change to a 10am meeting, shouldn't it - isn't that what happens in the real world?

Avatar
Dr Obx
-

Nope, if I have a meeting at 9.00am whatever happens and regardless how many hours time will be shifted, meeting will still be at 9.00am while calendar will tell you "meeting at 10:00am" which is not true so I will be one hour late ;) Time change shouldn't affect meeting time.

Avatar
Dr Obx
-

This is definitely a big issue and apparently nobody spotted it before. If you setting up daily alarm and must wake up on time to go to work .... and then there will be a time change, is your alarm will ring at the same time or +/- one hour ? YES! It will still show the same time so if you must wake up at 7:00 it will wake you up at 7:00 regardless not at 6:00 or 8:00 it should be the same with recurrent events. Whatever you do time should stay the same in the same time-zone. Of course if a person who must participate in this event but is in different time zone system should calculate the time difference but it should be visible only for this person(other tz) for example 7:00am my time will be 10:00 am of his time.

Avatar
SIRIUS-INFO
-

Hello, I have the same problem, twice a year I have to change all my cron tasks. Idon't know what the solution is, any help would be appreciated..

Avatar
Dr Obx
-

It's not mine or your problem, it's a problem in general because it affects all Odoo users. :) Considering to dedicate one weekend and dig up whole code. Maybe it's only a tz problem. If so, I'll try remove it ...

2 答案
0
Avatar
Landis Arnold
Best Answer

(UPDATE / Correction).  This all seemed related to "Daylight Savings Time and Errors with Odoo USER TIME:

Re-Setting my User TimeZone from Denver to  Los Angeles did start to fix the error.  Then I found, moving back to Denver and some page reloads/ logins/ logouts, got the error to go away.

Ie:  Denver then Los Angeles then Denver again  with  Page Close and Reopen, did finally get all time presentations aligned and Odoo 8's sensed TimeZone Error to go away.  All times are correct on both User/Browser Machines and the Server.


Initially after moving back from Los Angeles to Denver in the Odoo settings the error returned, but then it was gone.  Had been consistent for at least 2 days before these changes.  I am "Red Green" colorblind and did not easily notice the Red Alarm Sign in my page head.


---------------


Well,  I am not really synching with Google Calendar, but I realized that my timesheets were logging the wrong time by an hour.  There was a "Spring Forward" event a few weeks ago...

Strange debug  (I am running Odoo 8 on Debian Server).

Debian Server has correct UTC and Denver Time Zone

Ran this to be sure, and all was correct:  dpkg-reconfigure tzdata

My primary Chrome and Firefox system was giving me a "Red" Alarm:

                     odoouser time does not match what is set in settings or browser time

On One machine recently installed, I was getting the error in Chrome but Not in Firefox.  In another machine, my main one, the error was in both Chrome and Firefox.  I did find a setting on the new machine to  have Windows track time adjustments (day light savings time)..  That just made the problem consistent in all browsers.

The "working" solution I found for my needs was changing the USER Time Zone (I am a one person show) to "America/Los_Angeles"  from what it should be "America/Denver".  Not elegant at at all and likely could cause large issues if synching, say, with Google Calendar, but I just need my log times to be correct.

I expect there are some fixes to this in, say V 12, but it appears that this has been an ongoing issue.  Some people have posted commands that can somehow change the Postgres DateTime calculations but I did not want to go there just now.

Hope this is helpful.  In a Pinch, act like you are in a nearby timezone.    Seems an issue in the Odoo Code.




头像
丢弃
0
Avatar
Marco Viviani
Best Answer

Hi,
almost 3 years have passed and I have exactly the same problem.
Do you have any update about this issue?
I am working around it but still no solution...

Thank you and best regards

3 注释
头像
丢弃
Avatar
Dennis Ochse
-

This has become a real problem for us as well.

Can you share your work around method?

Avatar
Dr Obx
-
Hello there, I was off the Odoo for some time so I'm not sure if the problem is already solved.
Check Odoo forum please.
Regards
Rob


On Tue, 26 Mar 2019 at 08:28, Dennis Ochse <d.ochse@open2bizz.nl> wrote:

This has become a real problem for us as well.

Can you share your work around method?

Sent by Odoo S.A. using Odoo.

Avatar
Marco Viviani
-

Hello every one,

a fast update about this Google Calendar issue.

We solved the bug related to the event time changing from Winter/Summer (and Summer/Winter).

We will release it to the community asap (unless someone else already fixed it) for Odoo version 12.0 (we are migrating to the newest release).

Unfortunately, we discovered another little bug, which is more from Google side than Odoo's:

In Google Calendar, if an event of a recurring serie is modified, it generates an EXDATE line in .ics file which is not recognized by Odoo during synchronization.

Thus, errors and duplications are generated.

As far as we know, to solve this bug we should edit Odoo's base module, but this option is too hard for us at the moment.

So, we are going to open a bugfix request - and to do that, if you have any information about this, it is highly welcome.

Fix will be released as soon as the EXDATE problem will be solved.

Thanks and best regards,

Marco