Odoo Help

0

Backup/Restoring a Large Database using PSQL dump with Filestore?

By
inian
on 18-2-9 上午9:48 151 views

Hi Guys,

I am using Odoo 11 CE

I tried to backup and restore by database by PSQL dump.

Step1 : Backup my database named rck_test5

sudo pg_dump -U rck10 -h localhost -p 5432 rck_test5 > /odoo/backups/new

Step2: Created new db

createdb -O rck10 rck_test6

Step3: Restore the database

psql -U rck10 -d rck_test6 -f /odoo/backups/new

Everything works fine. But when restored, I am missing all icons and images attached.

I found that these files are stored in ./local/share/Odoo/filestore/dbname when we create or restore database from ui.

When we restore using UI, filestore is zipped and restored properly.

But when we want to restore a database that is more than 10 GB, it is adviced to use psql dump.

I tried setting data_dir path in odoo-server.conf. But it does not generate filestore.

I need to know how to backup and restore filestore using command line. (Reason : I get to see full log of what is happening when we restore a huge database)

Please guide how to

* Backup a filestore

* Restore a filestore

* Update path in ir_attachement.location

to set odoo to read the new filestore location. Please guide me

0
Sunny Dev
On 18-2-10 上午1:00

hi,


first you go into your filestore directory, and existing directory copy and paste with new db name.

in your case,

  • now you first delete created automatically Filestore folder in directory.

    • cd  ./local/share/Odoo/filestore/

    • apply command ==>  sudo rm -R rck_test6

  • after  that copy existing filestore db and paste with new name.

    • sudo cp -R  rck_test5 rck_test6


    after restart your server and check, all icons and images are displayed same as old db.


I hope it will help you.


Thanks



Hi Sunny,

Thanks for your response, but I cannot copy or paste into ./local/share/Odoo/filestore/

Remove "rm" works but no other command works.

inian
on 18-2-12 上午2:05

can you tried with "sudo" command?

Sunny Dev
on 18-2-12 上午5:08

Tried that too, I don't get any errors.nothing can be copied from there. Some how odoo can write or copy when we take backup/restore from UI.

inian
on 18-2-12 上午5:20

not sure, but it maybe comes from "web" module for backup via UI.

Sunny Dev
on 18-2-12 上午6:09

My concern is it is ok to backup a small database using web UI. But can same be used for backing up a database that is large.

inian
on 18-2-12 上午7:16

About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now

Question tools

1 follower(s)

Stats

Asked: 18-2-9 上午9:48
Seen: 151 times
Last updated: 18-2-10 上午1:00