Help

4

How to tag Users to Company ?

Avatar
priyankahdp

As Administrator I created two companies called MLC & BLC. I Created two users also called Chris & Tom.

I need to tag Chris to MLC company & Tom to BLC.but when i tried in OpenERP 7 Its gives below error.please advice me to sort this issue.

ValidateError

Error occurred while validating the field(s) company_id,company_ids: The chosen company is not in the allowed companies for this user

@ Priyesh

Still unable to find Allowed Companies

image description

1 备注
头像
丢弃
Avatar
Manish Ashar
-

@Priyesh - It is an question to you and not an Answer to Priyank.

I followed all the steps suggested by you but still I am not getting the option to configure "Allowed Companies"

2 答案
8
Best Answer

You need to add that company first in Allowed Companies, defined in Access Rights tab. Add that company, you want to assign to a user, in that tab and after that, Add it from main Company field. It will work fine.

Thanks, Priyesh Solanki

8 注释
头像
丢弃
Avatar
priyankahdp
-

Thanks Priyesh. where is the place to select 'Allowed Companies' ?

Avatar
Priyesh Solanki (pso)
-

In User form, Second tab Access Rights , at the top side! You will see Allowed companies over there. Add your company in that , you want to assign to that user.

Avatar
priyankahdp
-

@Priyesh: Post updated.please check and advice,if u can plz upload pic for that

Avatar
Priyesh Solanki (pso)
-

It seems that You did not assign Multi Companies group to your current logged user. If you are login with Administrator, Open its form view, Go to Access Rights and at below, Tick the boolean 'Multi Companies' , Save it. Reload it. Re-open the User form view and you will be able to see Allowed Companies tab in Access Rights.

Avatar
priyankahdp
-

Wow..thanks Priyesh.u saved my day..!

:-)

Avatar
Arslan Zafar
-

Thanks, That really helped.

Avatar
Manish Ashar
-

After doing the Tick the boolean 'Multi Companies' , Save it. Reload it. Re-open the User form view I could not get Allowed Companies tab in Access Rights. Please help.

Avatar
Ken Tong
-

Hi, I have tick the option muti companies, save and reload. I still did not find the allowed company. Kindly refer to the attach. https://dl.dropboxusercontent.com/u/42025188/MultiComp.png https://dl.dropboxusercontent.com/u/42025188/no_allowed.png

0
Avatar
Karolin Ar.
Best Answer

Check 'Multi-Company' checkbox from 'Administrator' user panel, then you can see the 'Allowed Company' filed in user's settings. Resolved for me, Thank you.

 

 

 

 

头像
丢弃