Trợ giúp

2

Longpolling Error: Function declared as capable of handling request of type 'json' but called with a request of type 'http'

Avatar
Marius Stedjan

I'm getting a lot of this error in my logs:

odoo.http: , /longpolling/poll: Function declared as capable of handling request of type 'json' but called with a request of type 'http'

This seems to have started all of a sudden. I've tried editing the nginx config, but nothing seems to help.

Have anybody else experienced this error?

Odoo config:

[options]

admin_passwd = password

db_host = False

db_port = False

db_user = odoo

db_password = password

dbfilter = dbname

addons_path = /usr/lib/python2.7/dist-packages/odoo/addons

addons_path = /odoo/enterprise,/odoo/odoo-server/addons,/odoo/custom/themes,/odoo/custom/addons,/odoo/custom/modules

logfile = /var/log/odoo/odoo-server.log

logrotate = True

xmlrpc_interface = 127.0.0.1

xmlrpc_port = 8069

longpolling_port = 8072

proxy_mode = True

workers = 8

limit_memory_hard = 1677721600

limit_memory_soft = 629145600

limit_time_cpu = 600

limit_time_real = 1200

max_cron_threads = 1

Nginx config:

# workaround for nginx's inability to escape the $ character. see:

# https://openresty.org/download/agentzh-nginx-tutorials-en.html#nginx-variables-escaping-dollar

geo $dollar {

default "$";

}

upstream odoo {

server 127.0.0.1:8069 weight=1 fail_timeout=0;

}

upstream odoo-im {

server 127.0.0.1:8072 weight=1 fail_timeout=0;

}

# Proxy Headers

proxy_set_header Host $host;

proxy_set_header X-Forwarded-Host $host;

proxy_set_header X-Real-IP $remote_addr;

proxy_set_header X-Forward-For $proxy_add_x_forwarded_for;

proxy_set_header X-Forward-Proto $scheme;

# General Proxy Config

proxy_connect_timeout 3600s;

proxy_send_timeout 3600s;

proxy_read_timeout 3600s;

proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;

# Increase Proxy buffer to handle large Odoo web requests

proxy_buffers 16 64k;

proxy_buffer_size 128k;

# Redirect www. to bare domain

server {

listen 80;

server_name www.domain.com;

return 301 http://domain.com$request_uri;

}

server {

listen 443 ssl;

ssl_certificate /etc/nginx/ssl/domain.com.chained.crt;

ssl_certificate_key /etc/nginx/ssl/domain.com.key;

server_name www.domain.com;

return 301 https://domain.com$request_uri;

}

server {

listen 80;

server_name domain.com;

# Log file locations

access_log /var/log/nginx/domain.access.log;

error_log /var/log/nginx/domain.error.log;

#Redirect non-POS and related content in https to allow POS in http

location ~ ^(?!/pos/|/web/binary/company_logo|/aspl_pos_prod_operation/static/|/?[^/]*/website/action/|/web/webclient/|/web/content/|/web_editor/static/|/web/css/|/web/static/|/point_of_sale/static).*$ {

proxy_redirect off;

if ($request_method != POST) {

# rewriting a POST request has no sense as the browser will do the request as GET

rewrite ^(.*)$ https://$host$1 permanent;

}

if ($request_method = POST) {

proxy_pass http://odoo;

}

}

location = /longpolling/poll {

proxy_redirect off;

proxy_pass http://odoo-im;

}

location / {

proxy_redirect off;

proxy_pass http://odoo;

}

}

server {

listen 443 ssl;

server_name domain.com;

# Log file locations

access_log /var/log/nginx/domain.access.log;

error_log /var/log/nginx/domain.error.log;

# Enable SSL

ssl on;

ssl_certificate /etc/nginx/ssl/domain.com.chained.crt;

ssl_certificate_key /etc/nginx/ssl/domain.com.key;

ssl_session_timeout 30m;

keepalive_timeout 600;

ssl_ciphers 'ECDHE-RSA-AES128-GCM-SHA256:ECDHE-ECDSA-AES128-GCM-SHA256:ECDHE-RSA-AES256-GCM-SHA384:ECDHE-ECDSA-AES256-GCM-SHA384:DHE-RSA-AES128-GCM-SHA256:DHE-DSS-AES128-GCM-SHA256:kEDH+AESGCM:ECDHE-RSA-AES128-SHA256:ECDHE-ECDSA-AES128-SHA256:ECDHE-RSA-AES128-SHA:ECDHE-ECDSA-AES128-SHA:ECDHE-RSA-AES256-SHA384:ECDHE-ECDSA-AES256-SHA384:ECDHE-RSA-AES256-SHA:ECDHE-ECDSA-AES256-SHA:DHE-RSA-AES128-SHA256:DHE-RSA-AES128-SHA:DHE-DSS-AES128-SHA256:DHE-RSA-AES256-SHA256:DHE-DSS-AES256-SHA:DHE-RSA-AES256-SHA:AES128-GCM-SHA256:AES256-GCM-SHA384:AES128-SHA256:AES256-SHA256:AES128-SHA:AES256-SHA:AES:CAMELLIA:DES-CBC3-SHA:!aNULL:!eNULL:!EXPORT:!DES:!RC4:!MD5:!PSK:!aECDH:!EDH-DSS-DES-CBC3-SHA:!EDH-RSA-DES-CBC3-SHA:!KRB5-DES-CBC3-SHA';

ssl_protocols SSLv3 TLSv1 TLSv1.1 TLSv1.2;

ssl_prefer_server_ciphers on;

# Increase maximum accepted body size

client_max_body_size 512m;

# Increase Proxy buffer to handle large Odoo web requests

proxy_buffers 16 64k;

proxy_buffer_size 128k;

# General Proxy Config

proxy_connect_timeout 3600s;

proxy_send_timeout 3600s;

proxy_read_timeout 3600s;

proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;

# Default Settings

proxy_redirect off;

proxy_buffering off;

# Enable gzip

gzip_types text/css text/less text/plain image/svg+xml text/xml application/xml application/json application/x-font-ttf font/opentype application/javascript application/xhtml+xml;

gzip on;

location /images {

root /var/www;

autoindex on;

}

# Redirect POS to http

location ~ ^/pos/ {

rewrite ^(.*)$ http://$host:80$1 permanent;

}

location /longpolling {

proxy_redirect off;

proxy_pass http://odoo-im;

}

location / {

proxy_redirect off;

proxy_pass http://odoo;

}

# cache some static data in memory for 60 mins.

location ~* ^/(openerp|openobject|web)/static/ {

proxy_cache_valid 200 60m;

proxy_buffering on;

expires 864000;

proxy_pass http://odoo;

}

}

1 Bình luận
Ảnh đại diện
Huỷ bỏ
Avatar
Samo Arko
-

have you fixed this error? I'm having the same one.