Допомога

1

Timeout error with nginx

Avatar
Paulo Matos‏

Hi there.

After install nginx and setup reverse proxy for my instance, I am gettings a timeout error whille installing a module.

I have tested directly by instance IP address and it works fine.

The message is:

XmlHttpRequestError Gateway Time-out

<html>

<head><title>504 Gateway Time-out</title></head>

<body bgcolor="white">

<center><h1>504 Gateway Time-out</h1></center>

<hr><center>nginx/1.4.6 (Ubuntu)</center>

</body>

</html>

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->

<!-- a padding to disable MSIE and Chrome friendly error page -->


Can anyone help me please.

Thank you in advance


Аватар
Відмінити
2 Відповіді
9
Avatar
Axel Mendoza
Найкраща відповідь

This happens because of nginx need a timeout to know if the servers proxied is processing or not the request. You can increase it to match your needs. I use this value for Odoo in nginx "location /"

proxy_read_timeout 300000;

3 Коментар
Аватар
Відмінити
Avatar
Paulo Matos‏
-

Thank you Axel. It solved my problem.

Avatar
Cliff Kujala
-

Thank you Axel. This solved my problems importing large CSV files to Odoo while using NGINX HTTPS Proxy.

Avatar
Axel Mendoza
-

I'm glad that this are solving problems

0
Найкраща відповідь

Thank you Axel. This solved my problems importing large CSV files to Odoo while using NGINX HTTPS Proxy . too...

Sharing Knowledge is great!

1 Коментар
Аватар
Відмінити
Avatar
Axel Mendoza
-

Glad to know that my contributions are still helping people after 5 years