Допомога

1

Scheduled action (Email Queue Manager) does not send automatically email from queue.

Avatar
Namal

            I am currently working on customizing the recruitment module. In it I have an interview schedule and feedback feature. The requirement is to send mail automatically to the interviewers once an interview is scheduled for a particular applicant.

Up to now,

  1. My  Outgoing Mail Servers test is successful
  2. I have set time to UTC in server and in Odoo Timezone to Asia\Colombo.
  3. I have been able to  auto generate mail using a Automated action to email queue with recipients as interviewers on create and update in the module
  4. I can send mails from queue manually by selecting.

           

            What is left to do is send all the mails in the queue automatically. The Scheduler seems to be running, but mails are not being sent. They continue to remain in the queue.   

Any help is greatly appreciated. 

6 Коментар
Аватар
Відмінити

Have you changed the interval for the 'Email Queue Manager' under Settings > Automation > Scheduled Actions? Sounds like you haven't modified this yet which would mean that e-mails are still in the waiting list until the date is passed that is set on our Queue manager.

Avatar
Namal
-

Yenthe I have set interval to 1 minute ...

Avatar
Namal
-

Yenthe I have set interval to 1 minute ...

Alright & no changes? Have you also changed the next execution date? By default changing the internal only works from the first time the next date is passed. If your old interval was a week it will not even before next week. So also set 'Next Execution Date' on today and about 5 mins from now!

Avatar
Namal
-

i did ... still no mail no email has been sent.

Avatar
Zbik
-

Verify how many you have a running server instances. Stop server, kill all other instances, start server.

2 Відповіді
0
Avatar
Harshit Agarwal
Найкраща відповідь

Method1

I tried to figure out the problem and found that the "Email Queue Manager" is scheduled for every one hour. Thus, the emails were triggered but only when the scheduler runs (i.e every 1 hour). You can update this by activating developer mode then Settings->Automation->Scheduled actions. Here select email queue manager and update interval. 

Method2

If the above method doesn't help, please verify your outgoing mail server if it is working by clicking on test connection.

Hope this helps.

Аватар
Відмінити