Допомога

1

Odoo session expired problem

Avatar
Samo Arko

First of all please no incognito window and such thing because they are NOT WORKING. I've tried everything that I found on google and nothing works.

As soon as I enable workers no one can log into Odoo anymore. It's just throwing Odoo Session Expired error. It doesn't work for normal users that have a single account and try to log in in the incognito window or in a different browser.

My odoo.conf

[options]
db_host = False
db_port = False
db_user = odoo
db_password = False
dbfilter = ^%h$
addons_path = /opt/odoo/odoo10/addons,/opt/odoo/customaddons
logfile = /var/log/odoo/odoo.log
log_level = error 
logrotate = True ;workers = 1

I'm running odoo 10 on Ubuntu 16.04 lts and using nginx.  

The nginx odoo configuration

upstream odoo {
        server 127.0.0.1:8069 weight=1 fail_timeout=3000s;
}

upstream odoo-lp {
        server 127.0.0.1:8072;
}

server {
    listen 80 default_server;
    listen [::]:80 default_server;
    server_name _;

    access_log  /var/log/nginx/odoo10.access.log;
    error_log   /var/log/nginx/odoo10.error.log;

    proxy_buffers 16 64k;
    proxy_buffer_size 128k;

    client_max_body_size 24000M;
    proxy_read_timeout 720s;
    proxy_connect_timeout 720s;
    proxy_send_timeout 720s;

    location / {
        proxy_pass  http://odoo;
        proxy_read_timeout 3000000;
        proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
        proxy_redirect off;
        proxy_set_header    Host            $host;
        proxy_set_header    X-Real-IP       $remote_addr;
        proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header    X-Forwarded-Proto https;
    }

    location /longpolling {
        proxy_pass http://odoo-lp;
    }

    location /xmlrpc {
        proxy_pass  http://odoo;
        proxy_next_upstream error timeout invalid_header http_500 http_502 http_503 http_504;
        proxy_redirect off;
        proxy_set_header    Host            $host;
        proxy_set_header    X-Real-IP       $remote_addr;
        proxy_set_header    X-Forwarded-For $proxy_add_x_forwarded_for;
        proxy_set_header    X-Forwarded-Proto https;
    }

    location ~* /web/static/ {
        proxy_cache_valid 100 30m;
        proxy_buffering on;
        expires 432000;
        proxy_pass http://odoo;
    }
}

I need workers enabled for longpolling. Hope someone knows how to help else I don't see any way of using odoo for any serious production ERP usage.






  

2 Коментар
Аватар
Відмінити
Avatar
Ermin Trevisan
-

Your configuration looks very strange to me, I don't understand it. Did you try it with a default configuration as described in the documentation?

Avatar
Samo Arko
-

for nginx or odoo

2 Відповіді
0
Avatar
Favio Náquira
Найкраща відповідь

You have to add on your longpolling:

proxy_set_header    Host            $host;
        proxy_set_header    X-Real-IP       $remote_addr;
        proxy_set_header    X-Forwarded-For $http_host;

Аватар
Відмінити
0
Avatar
Jaco
Найкраща відповідь

Same problem here since todays update to the latest docker image ...

Found new odoo:12 image (sha256:05e7683e382c9ee613bf6eb6c213450ec966b43aa6a85db4b2d224eec02b5d95)

Аватар
Відмінити