Yardım

2

Access Denied (Document type: Partner, Operation: read error)

Avatar
ali

hi,

i have facing problem in Portal->Billing->Quotation by User(portal group), when user click on any quotation to view than the following error popup.

Access Denied The requested operation cannot be completed due to security restrictions. Please contact your system administrator. (Document type: Partner, Operation: read)

2 Yorumlar
Avatar
Vazgeç
Avatar
dirtyHandsPHP
-

Same problem here, any update?

Avatar
Fred Blauer
-

I am having the same problem. Any idea?

10 Yanıtlar
7
Avatar
Malte Helmhold
En iyi cevap

I finally found out! it's a conflict of user permissions Access Levels. 

You have to experiment with the settings under User -> Permissions -> Other!!! 

A portal user has limited rights, so uncheck portal and uncheck public and just for debugging try to 

uncheck everything for a moment. Somehow this User/Survey is something I can't uncheck. But anyway, it's working now

and finally the user I had headache with can do what they want and they're real internal company users and have more accss rights

2 Yorumlar
Avatar
Vazgeç
Avatar
August Doo
-

this works for me, thanks Malte

Avatar
August Doo
-

this works for me, thanks Malte

5
Avatar
Narayanamurthy
En iyi cevap

Hi,

1. That error warning might be from the permission given to "res.partner" object for the perticular user group,

or

2. Check the record rule related to res.users,

settings->security->record rules

Avatar
Vazgeç
2
Avatar
E.R. Spada II
En iyi cevap

Yes, on the user/access rights, Under Other,  uncheck Contact Creation. This selection is actually reverse, unless Portal User.

 

Avatar
Vazgeç
1

I am agree with Malte Helmhold.

You are right. The portal and public user have some limited rights on some of the objects. So if one of the group has been assigned to user except admin, you will have access rights error/message.

Avatar
Vazgeç
1
Avatar
Thomas H.
En iyi cevap

Solved that with inactivating the user via settings / users / individual user - there deactivate the little box behind "active".

After that follow the description here to reactivate the user: https://www.odoo.com/forum/help-1/question/inactive-user-reactivation-32211

Avatar
Vazgeç
-4
Avatar
Rachid
En iyi cevap

try reinstall the base module using :

odoo.py -d YourDB -i base --without-demo=base

 

Avatar
Vazgeç