Odoo Help

2

0
14 Answers
6
Rakesh Sindhav Hindistan
26.11.2014 08:09

Hi,
1.- Download ZIP and extract http://www.reportlab.com/ftp/pfbfer.zip
2.- Create folder named "fonts" in " /usr/lib/python2.7/dist-packages/reportlab/"
3.- Copy content of folder extracted in "fonts" folder
4.- Restart server

5 Comments
Mibo, Michael Bos Hollanda
20.12.2014 03:18

Rakesh, I have the same problem. It crashes the server with the same fault as 92Trades has. Is there a proper fix available? I haven't found it yet!

Rakesh Sindhav Hindistan
22.12.2014 00:23

Have you attempted all the steps with the root permission on Ubuntu system ? And can you give me the configuration that you are using ? Try to start your server with [-d database name -u base] module. Hope it will solve your problem. Thanx.

Mibo, Michael Bos Hollanda
22.12.2014 01:46

I did Rakesh. I will try starting the server as you said. It works till the part where I try to print the report. It then makes me restart the whole system before I can acces Odoo again. A simple "service odoo restart" doesn't work, also stopping odoo and all afflicted processes and then restarting them also doesn't work. I updated to the newest nightly build and now it doesn't crash anymore. But it also doesn't show any barcode!

Rakesh Sindhav Hindistan
22.12.2014 02:27

Are you sure that you put all the fonts in the "/usr/lib/python2.7/dist-packages/reportlab/fonts/" directory with the Root permission from the extracted file http://www.reportlab.com/ftp/pfbfer.zip (Or download it again, may be file is crashed, Restart the System) ?

Budi Hartono Endonezya
26.08.2015 05:17

Rakesh, I want to thank you and confirm that this solution works for me. I use Ubuntu 14.04 with Odoo 8.0.

0
Dawari George Nijerya
9.12.2014 05:32

hello, your solution above does not work, infact it crases the system and keeps loading forever, is there a proper solution to fix the barcode issue on picking list please?

0
Robin Vincent Kanada
26.02.2016 07:10

Any help is much appreciated:

two days ago i followed this post and everything worked. I was able to print barcodes from the location page along with product codes.

Last night i was adding more locations and found out that it is no longer printing barcodes fomr the location page or the pick list page. However it does print barcodes form the product.

I have checked, permissions (everything is root) i have tried to redo the directions here with not effect the fonts folder is there and populated with files.

I have restarted odoo and the server and still just a box where the barcode should be.

The server does not hang and in fact works great other no bar codes.

I have tailed the logs for odoo, apache and syslog with not meaningful results.

Does anyone have any idea where i should look next?

0
Fernando Amerika Birleşik Devletleri (A.B.D.)
30.10.2015 14:52

I want to say the above answer is fine. I solved the problem in that way and I have windows 7. thanks a lot.

Note: Remember to restart the server.

Ask a Question
Keep Informed
4 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now