Community mailing list archives

community@mail.odoo.com

Avatar

Re: POS nginx disabling ssl for /pos/web route

by
Ryan Cole
- 01/02/2017 15:28:37
Hello,


Are you having issues with mixed-content warnings from the browser?

If this is the case, it may be better to disable the warnings, rather than attempting to de-HTTPS the specific routes used by the POS. Disabling HTTPS on /web/session could cause other problems with the website/backend, and could leave your Odoo instance vulnerable to attacks.

AFAIK, Odoo only communicates via non-HTTPS with the local PosBox, so disabling these warnings shouldn't cause any security issues, assuming your local network is secured.


This is a problem that should be fixed in the point_of_sale module.


Cheers,
Ryan




From: "4fuss" <jamkurendal@gmail.com>
To: "Community" <community@mail.odoo.com>
Sent: Thursday, February 2, 2017 1:40:19 AM
Subject: POS nginx disabling ssl for /pos/web route

Hello Community,

I have problem configuring nginx to work with POS with ssl. As 
documentation suggests I disabled ssl for location /pos/web but in that 
configuration some requests like for /web/session/get_session_info are 
passed as http type but the method should be called with json request. I 
suppose there is something wrong with my redirection configuration on 
nginx.

Can anybody provide me with exemplary nginx configuration, please?

_______________________________________________
Mailing-List: https://www.odoo.com/groups/community-59
Post to: mailto:community@mail.odoo.com
Unsubscribe: https://www.odoo.com/groups?unsubscribe


Reference