Community mailing list archives


Re: Project Task Addition - VERY SLOW

Thang Duong Bao
- 17/10/2017 12:48:25

You could try using postfix as proxy for your real mail server: Odoo --> Postfix (localhost) --> Your email server

Cause connection from Odoo --> Postfix is local, the delay time will decrease significantly.

Bellow is example config on Ubuntu 16.04 server:

# install postfix
sudo apt-get install postfix mailutils libsasl2-2 ca-certificates libsasl2-modules

# example: edit config file to send email using Gmail:
nano /etc/postfix/

# add following line:
relayhost = []:587
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options = noanonymous
smtp_tls_CAfile = /etc/postfix/cacert.pem
smtp_use_tls = yes
# overwrite Postfix default value
mailbox_size_limit = 0
message_size_limit = 0
virtual_mailbox_limit = 0
inet_protocols = ipv4

# create store password file:
nano /etc/postfix/sasl_passwd

# add your password:

# update permission
sudo chmod 400 /etc/postfix/sasl_passwd
sudo postmap /etc/postfix/sasl_passwd

# validate certificates to avoid running into error
cat /etc/ssl/certs/thawte_Primary_Root_CA.pem | sudo tee -a /etc/postfix/cacert.pem

# Finally, reload postfix config for changes to take effect:
sudo /etc/init.d/postfix reload

In Odoo, setting out-going email server is localhost, using port 25.

Best regards,
Thang Duong Bao
Mobile: (+84) 918 753 062

On Tue, Oct 17, 2017 at 10:50 PM, Arlosyst <> wrote:
Does anyone have an idea for it?

On Tue, Oct 17, 2017 at 12:22 AM, Arlosyst <> wrote:
Hi All,

I have created a project in Odoo with 5 followers. Whenever I create a task in Odoo it takes 15 seconds to complete the activity as in the background is sending mail to all the followers.

Is there a way by which we can tune up this process?


Post to: