Community arquivos das listas de correio


Re: OS X El Capitan 10.11 Odoo Server Error

Vauxoo S.A. de C.V., Moisés Augusto López Calderón
- 01/10/2015 15:36:32
Thank for info.

2015-10-01 13:08 GMT-05:00 Suhendri Wijaya <>:

Hi All,

This issue is solved. 

libpq.5.dylib need to be replaced. 

sudo mv /usr/lib/libpq.5.dylib /usr/lib/libpq.5.dylib.old
sudo ln -s /Library/PostgreSQL/9.4/lib/libpq.5.dylib /usr/lib

But in order to replaced, we need to disable SIP. 

Best Regards,
Suhendri Wijaya

On Oct 1, 2015, at 22:39, Suhendri Wijaya <> wrote:

Hi All,

I'm using Mac with Odoo v8 installed in OS X Yosemite 10.10 and works fine. I'm using Postgre SQL 9.4.4. This morning just upgraded to OS X El Capitan 10.11 and server is not running with errors as below: 

File "/Users/Hok/Odoo/v8/openerp/", line 57, in <module>
    import psycopg2
  File "/Library/Python/2.7/site-packages/psycopg2/", line 50, in <module>
    from psycopg2._psycopg import BINARY, NUMBER, STRING, DATETIME, ROWID
ImportError: dlopen(/Library/Python/2.7/site-packages/psycopg2/, 2): Library not loaded: libpq.5.dylib
  Referenced from: /Library/Python/2.7/site-packages/psycopg2/
  Reason: unsafe use of relative rpath libpq.5.dylib in /Library/Python/2.7/site-packages/psycopg2/ with restricted binary

If somebody has fixed it, please let me know. Thanks.

Best Regards,
Suhendri Wijaya

Post to:

Moisés López Calderón
Vauxoo - OpenERP's Gold Partner
Mobile: (+521) 477-752-22-30
Office: (+52) 477-773-33-46
twitter: @vauxoo