Odoo Help

2 Answers
Kevin Peterson
14/05/18 08:21


 city_id = fields.Many2one('res_city', 'City', required=True)

try changing this to

 city_id = fields.Many2one('res.city', 'City', required=True)

res_city to res.city

14/05/18 14:05

Hi Kevin,

I tried before posted question without delete database, it doesn't work.

Currently, I tried with delete database then re-install all related modules, it's working, many thinks for your suggestion. You gave me more confident that this way should work.

Noted: when checked database before posted question there is table res_city where I added a row:

 id |    name     | country_id | state_id | create_uid |        create_date         | write_uid |         write_date 


  1 | Saphan-sung |        217 |      679 |          1 | 2018-05-14 10:30:27.965798 |         1 | 2018-05-14 10:30:27.965798

(1 row)

And try checked import path odoo.addons.base_address_city.models.res_city, its available.

Ask a Question
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now