Odoo Help


5 Answers

The user using which you are trying to access the database may not be SUPERUSER access privileges.

So make sure that the user through which you are trying to login database must be SUPERUSER and if not then run following steps in terminal which will alter user into SUPERUSER:

1) psql template1 2) ALTER USER user_name WITH SUPERUSER; (user_name = The user by with you are going to restore the database. It gives SUPERUSER access privileges to user_name)

1 Comment
19/08/15 05:08

Hi Vijay, still i am facing the same problem is there any suggestions please give me.

26/03/16 05:00

I face same problem. I waste almost half day to resolve this problem, problem is there are two odoo server live and testing on same machine with different database user.In browser login to testing server and close the page and again try to login to live server from same browser and checking log. Odoo try to login testing database from live code base and same error raised. So just clear browser cache py pressing ctrl + shift + Del and delete everything, problem solved.


Suhas it work for me your answer thankyou

15/12/16 10:02

Hi,  I have a similar problem pls . when I get up my second odoo (with an second process script)

1.        I have two config files in  /etc/odoo/  --->openerp-server.conf    :8069 (defalut)

                                                             --->choclito-server.conf    :8169

(also I use xmlrpc=8169 to point my port, and )

2.        I have two owner in my  postgresql  --> odoo    -->odoopass   (defalut)

                                                             --> choclito    ---> choclitopass

(my first database called db1 , and my second is db2)

3.        and I have two process script in /etc/init.d/ --> odoo  (defalut)

                                                            ------------> choclito

all my config files have permission odoo:odoo ( , except in /etc/init.d/   because they are from root)

(i have nginx with my web srv, but I don think so , becausa my ports listen ok, I think is some related to my database , I dont know )      :(

... and this is my log from my second odoo (when I run choclito , but my first odoo was already running before):


2016-12-15 14:34:05,694 7431 INFO db1 werkzeug: - - [15/Dec/2016 14:34:05] "GET / HTTP/1.1" 500 -2016-12-15 14:34:05,700 7431 ERROR db1 werkzeug: Error on request:
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 177, in run_wsgi    execute(self.server.app) 
File "/usr/lib/python2.7/dist-packages/werkzeug/serving.py", line 165, in execute    application_iter = app(environ, start_response) 
File "/usr/lib/python2.7/dist-packages/openerp/service/server.py", line 291, in app    return self.app(e, s) 
File "/usr/lib/python2.7/dist-packages/openerp/service/wsgi_server.py", line 216, in application    return application_unproxied(environ, start_response) 
File "/usr/lib/python2.7/dist-packages/openerp/service/wsgi_server.py", line 202, in application_unproxied    result = handler(environ, start_response) 
File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 1297, in __call__    return self.dispatch(environ, start_response) 
File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 1271, in __call__    return self.app(environ, start_wrapped) 
File "/usr/lib/python2.7/dist-packages/werkzeug/wsgi.py", line 579, in __call__    return self.app(environ, start_response) 
File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 1435, in dispatch    ir_http = request.registry['ir.http'] 
File "/usr/lib/python2.7/dist-packages/openerp/http.py", line 353, in registry    return openerp.modules.registry.RegistryManager.get(self.db) if self.db else None 
File "/usr/lib/python2.7/dist-packages/openerp/modules/registry.py", line 339, in get    update_module) 
File "/usr/lib/python2.7/dist-packages/openerp/modules/registry.py", line 370, in new    openerp.modules.load_modules(registry._db, force_demo, status, update_module) 
File "/usr/lib/python2.7/dist-packages/openerp/modules/loading.py", line 289, in load_modules    graph.add_module(cr, 'base', force) 
File "/usr/lib/python2.7/dist-packages/openerp/modules/graph.py", line 89, in add_module    self.add_modules(cr, [module], force) 
File "/usr/lib/python2.7/dist-packages/openerp/modules/graph.py", line 129, in add_modules    self.update_from_db(cr) 
File "/usr/lib/python2.7/dist-packages/openerp/modules/graph.py", line 78, in update_from_db    ' WHERE name IN %s',(tuple(additional_data),) 
File "/usr/lib/python2.7/dist-packages/openerp/sql_db.py", line 158, in wrapper    return f(self, *args, **kwargs) 
File "/usr/lib/python2.7/dist-packages/openerp/sql_db.py", line 234, in execute    res = self._obj.execute(query, params)ProgrammingError: permission denied for relation ir_module_module

Ask a Question
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Odoo Training Center

Access to our eLearning platform and experience all Odoo Apps through learning videos, use cases and quizzes.

Test it now