Odoo Help

0

0
2 Answers
2
Avatar

Dipak Shah

--Dipak Shah--

5414
| 6 3 8
New Delhi, Índia
--Dipak Shah--


Dipak Shah
31/01/18 01:25

Hello Martin Schubert,

By Setting only workers is not enough you have to configure few things,

: (parameter of odoo/postgres database).

1> IN odoo config :   

    limit-memory-soft,limit-memory-hard

2> IN postgres (database) :

    max_connections,shared_buffers,effective_cache_size,work_mem

    maintenance_work_mem,checkpoint_segments,checkpoint_completion_target

    wal_buffers,default_statistics_target.

  • To share the workload between workers mostly you need to divide and allocate memory in such a way so its depending on the system config. (e.g Hard disc Type, Memory (RAM), Size of it,version of postgres and your O.S) .

You do not need to worry about it ,just go through either of below URL to boost up your server speed.

http://pgtune.leopard.in.ua

https://github.com/gregs1104/pgtune

HOPE this will help you a lot !

Many Thanks.


0
Martin Schubert
11/03/18 06:29

TV-Show is done and Odoo ran stable.

Visitors: 27k, concurrend 10k

with this settings:

- Hardware: Google Cloud instance with 64 vCPUs, 240gb RAM, 20gb SSD

- workers = 100

- limit_memory_hard = 1677721600 (1,6GB)

- limit_memory_soft = 1073741824 (1GB)

- http://pgtune.leopard.in.ua/

Load average:

CPUs: 30%

RAM: 25GB

Ask a Question
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our eLearning platform and experience all Odoo Apps through learning videos, use cases and quizzes.

Test it now