Community Mailing lijst archieven

Re: [9.0] Images not uploading to Odoo

Piyush Suva
- 01-12-2015 02:19:05
      I was also facing the same issue , but after upgrade 'werkzeug' , its work fine.

$ sudo pip install --upgrade werkzeug

Piyush Suva
Mo. +91 94277 21188
Odoo/OpenErp TechnoFuctional Consultant

On Tue, Dec 1, 2015 at 12:33 PM, Jason / 崔建平 <> wrote:

It is caused by jpeg decoder on the system. You can refer to the message from this mailing list dated Nov 27th 15:13 with subject Re: [9.0] Unable to use a closed cursor - on Fresh odoo install form git. It was well documented on how to fix the problem.


I also have one instance in which difficulties were found to solve the problem. Re-installing the OS and updating Pillow solved it.




From: [] On Behalf Of Cocopapa
Sent: Tuesday, December 1, 2015 2:08 PM
To: Community <>
Subject: [9.0] Images not uploading to Odoo




We are facing the problem that we can't upload any images anymore to the site.


We googled and have reinstalled already


Root Cause: Pillow (JPEG decoder) bug on ubuntu > 14.04


Resolution: update jpeg library, then reinstall pillow.


# install libjpeg-dev with apt

sudo apt-get install libjpeg-dev


# reinstall pillow

pip install -I pillow


# restart Odoo, or else no effect until it is restarted.


But the problem still the same.


Any idea is appreciated on how to resolve that issue


1.  To upload the images we clicked on an image we want to exchange

2.  go to upload from computer - or uploud without optiization (effect is the same - not loading)

3.  it is truning endless

4.  The error log unfortunately says nothing at all concerning the upload process.





Post to:

Post to: