Help

0

sitemap.xml is rendered with "×" as first line

I'm having problems with the generated sitemap.xml

When downloading the sitemap, it's generated with "×" as the first line.
This breaks the xml format, so it doens't work.

I'm using Odoo v10, recently pulled.
No custom modules are inheriting the sitemap_xml_index() method or any of the related templates.

Any ideas? Thanks!  

2 Opmerkingen
Avatar
Negeren
Avatar
Fatih Piristine
-

check your sitemap.xml template there might be something wrong.

Avatar
Marius Stedjan
-

The sitemap.xml template is not edited, so it's vanilla Odoo. It looks fine, and it does not have "×" anywhere in it. It's weird.. I can't figure out where it is added.

1 Antwoord
1
Avatar
Jorunn D. Newth
Beste antwoord

Did you figure this out? I'm not sure how or when it happens, because I could swear I have fixed this multiple times now meaning something resets it, but on our site at least it's a "translation" issue -- I'm guessing you also have the Norwegian language pack activated?

What I do to change it is open the view (Settings > Technical > Views), search for sitemap, and then for both sitemap_xml and sitemap_index_xml, I go to edit the translations, which is where "×" is hiding.

1 Opmerking
Avatar
Negeren
Avatar
Marius Stedjan
-

This fixed the issue!

Yes, I’m using the Norwegian translations.

I’ll do some digging in the code to see if I can find anything that might cause this.

Does it reset after you to a db upgrade?

Tusen takk :)