Odoo Help

0

0
2 Antwoorden
0
Adaki Spanje
26-06-19 10:28

Hi Niyas,

Odoo is using Python 3.6. Here launch process:

[root@server venv]# sudo systemctl status odoo12*
odoo12.service - Odoo12
Loaded: loaded (/etc/systemd/system/odoo12.service; enabled; vendor preset: disabled)
Active: active (running) since Wed 2019-06-26 16:15:01 CEST; 1min 23s ago
Main PID: 7683 (scl)
CGroup: /system.slice/odoo12.service
|-7683 /usr/bin/scl enable rh-python36 -- /opt/odoo12/venv/bin/python3 /opt/odoo12/odoo/odoo-bin -c /etc/odoo12.conf
|-7694 /bin/bash /var/tmp/scljt1CKJ
`-7704 /opt/odoo12/venv/bin/python3 /opt/odoo12/odoo/odoo-bin -c /etc/odoo12.conf​

I verify that PyPDF2 package is in this folder: /opt/odoo12/venv/lib/python3.6/site-packages

drwxrwxr-x 3 odoo12 odoo12 4096 Mar 26 15:03 PyPDF2
drwxrwxr-x 2 odoo12 odoo12 4096 Mar 26 15:03 PyPDF2-1.26.0-py3.6.egg-info​


File permission are correct too...

Until tomorrow, Odoo worked very well, but suddenly, since yesterday, service get down very frecuently. And we did not do any change or module install last weeks.

Thanks!

2 Opmerkingen
Adaki Spanje
01-07-19 03:13

Hi,

I can't solve this problem...

I tried commenting this line:

#from . import pdf

from "/opt/odoo12/odoo/odoo/tools/__init__.py" file.

But now, I have another error:

File "/opt/odoo12/odoo/odoo/tools/config.py", line 18, in <module>

odoo12[14510]: from passlib.context import CryptContext

odoo12[14510]: ModuleNotFoundError: No module named 'passlib'

systemd[1]: odoo12.service: main process exited, code=exited, status=1/FAILURE

systemd[1]: Unit odoo12.service entered failed state.

systemd[1]: odoo12.service failed.

I am so lost...

Adaki Spanje
01-07-19 08:44

SOLVED!!!!!

I have solved the problem installing all dependencies this way:

/opt/rh/rh-python36/root/usr/bin/pip3.6 install PyPDF2

0
Avatar

Niyas Raphy India

--Niyas Raphy--
26373
| 7 7 11
Wayanad, Kerala, India
--Niyas Raphy--

Odoo Techno Functionalist

Feel free to connect :  niyasraphyk@gmail.com

Twitter:https://twitter.com/niyasraphy
LinkedIn: https://www.linkedin.com/in/niyasraphy/
FB:https://www.facebook.com/niyasraphy123
Whatsapp : +917736136763
Happy to help :)

Niyas Raphy India
26-06-19 10:14

Hi,

Make sure that Odoo is running using the same python interpreter in which the package is installed in. Also after installing the package did you restart the odoo service? If not restart the service.


Thanks

Stel een vraag
Schrijver
Blijf op de hoogte
1 volger(s)
Over deze community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now