Odoo Help


7 Answers

Similar problem on my Ubuntu instance. Specifically
'ffi.h: No such file or directory'

I googled around and found this post

It suggested installing some sort of 'essentials package' using the code
sudo apt-get install build-essential libssl-dev libffi-dev python-dev

That worked no problem

I then used the code from the post by Yenthe
sudo pip install pysftp

That worked
Running setup.py install for pysftp
Successfully installed cffi-1.6.0 cryptography-1.3.2 enum34-1.1.6 idna-2.1 ipaddress-1.0.16 paramiko-2.0.0 pyasn1-0.1.9 pysftp-0.2.8

No idea what the 'essentials' package is but it seemed to work...

Yossef Elsherif
10-07-17 08:53

@ Yenthe,

Thanks for your help, But i can't get it done.

I'm using a VM with Windows XP, and can't install pysftp or the auto-backup module

Julian Robbins
04-08-15 11:52

With Ubuntu 14.04, 64 bit install and with pip installed, I get an error during compilation when doing

sudo pip install pysftp


x86_64-linux-gnu-gcc -pthread -fno-strict-aliasing -fwrapv -Wall -Wstrict-prototypes -fPIC -std=c99 -O3 -fomit-frame-pointer -Isrc/ -I/usr/include/python2.7 -c src/MD2.c -o build/temp.linux-x86_64-2.7/src/MD2.o

src/MD2.c:31:20: fatal error: Python.h: No such file or directory

#include "Python.h"


compilation terminated.

error: command 'x86_64-linux-gnu-gcc' failed with exit status 1

As this is a vanilla Ubuntu install, I think there is another step such as installing dev headers but either way, I can go no further at the moment

1 Opmerking
19-11-15 03:12

same problem here

Naduni Pulsarani
25-06-15 06:50

@ Yenthe,

Thank u so much. This is working


Yenthe Van Ginneken

--Yenthe Van Ginneken--
| 9 9 12
--Yenthe Van Ginneken--

My Odoo blog: http://www.odoo.yenthevg.com/

My Twitter: https://twitter.com/Yenthe666

Yenthe Van Ginneken
24-06-15 10:44

Hi Naduni,

I assume you're the guy that asked me about how to install this on my blog?
If you're on Ubuntu open up a terminal and type the following command:

sudo pip install pysftp 

If you're on Windows you'll need to install the lib from the terminal. Open cmd and navigate in to the folder where pysftp-0.2.8 is located. After this you can execute the file to install:

cd ./pysftp-0.2.8/
setup.py install

In case you get an error about 'no module named setuptools' download this and install it too.

With kind regards,

1 Opmerking
16-02-16 05:39

Command /usr/bin/python -c "import setuptools, tokenize;__file__='/tmp/pip_build_root/pycrypto/setup.py'; exec(compile(getattr(tokenize, 'open', open)(__file__).read().replace('\r\n', '\n'), __file__, 'exec'))" install --record /tmp/pip-8b7HAk-record/install-record.txt --single-version-externally-managed --compile failed with error code 1 in /tmp/pip_build_root/pycrypto Storing debug log for failure in /home/giordano/.pip/pip.log Error

Stel een vraag
Keep Informed
2 volger(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now