Odoo Help

1

0
4 Answers
0
Michael Leff
15-03-18 14:19

I tried putting margins everywhere and nothing was working for me. As soon as I used padding instead, it worked fine. I just added a padding-top to the content of the page, and it spaced it nicely away from the header.

0
Florian Fischer
29-09-15 03:29

I also think the best way is to do it with the Paper Format. I usually create a new paperformat.xml in the data folder of my custom module. There you can inherit the record, so you don't have to change it by hand and it will stay the same no matter where you install your custom module:

<record id="report.paperformat_euro" model="report.paperformat">
    <field name="margin_top">50</field>
    <field name="margin_bottom">40</field>
    <field name="margin_left">7</field>
    <field name="margin_right">7</field>
    <field name="header_spacing">45</field>
</record>

0
Avatar

Shawn Varghese

--Shawn Varghese--
862
| 5 3 10
Dubai, Verenigde Arabische Emiraten
--Shawn Varghese--


Shawn Varghese
29-09-15 03:15

You could also try fiddling with the Header Spacing and Top Margin options in the Settings > Reports > Paper Format. Increasing Header Spacing would probably help push the body down

0
Juan Muñoz
25-09-15 10:45

You can create a new div which to contains all the report body.

Then you can add the following in the div: style="top:50px" and the body div should go down.

Hope that helps you! :)

Juan.

Stel een vraag
Writer
408
E.M.
Keep Informed
1 volger(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our eLearning platform and experience all Odoo Apps through learning videos, use cases and quizzes.

Test it now