도움말

0

Sitemap.xml created incorrectly with reverse proxy

Using the fresh Odoo installation I configured website, all went fine apart from the fact that sitemap.xml is pointing to localhost:port rather than address defined at web.base.url parameter (it was defined after the website configuration). 

As a site effect each time I login as admin to the system I am redirect to localhost. I setup web.buase.url.freeze to True but is does not help.

I deleted  sitemap.xml from attachments few times other last 2 days but with no improvement.

The system is installed with reverse proxy Nginx.

Anybody has experience with this type of the problem?

Avatar
Discard
2 응답
1
Avatar
Axel Mendoza
Best Answer

That's a problem of the running type of Odoo server(Gevent, Threaded or Prefork), they have the responsability of correctly handle reverse proxy headers like:

X_FORWARDED_HOST or X-FORWARDED-FOR 

and 

X-Forwarded-Proto or X-FORWARDED-PROTO

to correctly build wsgi environ. You still need to pass those headers from nginx to Odoo server.

Avatar
Discard
0

Indeed I did not setup that part in conf file. Thanks a lot!

1 Comment
Avatar
Discard

I am having this issue. How did you resolve it. What parameter name did you put in the config file? The answer here is not clear enough. Thanks