Odoo 도움말

1

0
8 응답
4
Avatar

Solanki Shamji India

--Solanki Shamji--

1366
| 5 2 9
Baroda, India
--Solanki Shamji--

Hello!

Solanki Shamji India
15. 10. 15. 오전 5:03

Try this in your .xml file

<field name="many2onefield" options="{'no_create': True, 'no_create_edit':True}" />

or

 < field name="many2onefield" widget='selection'/>

4 의견
Sairam Bandaru India
15. 10. 15. 오전 5:22

Yes.It worked for me. But I need to use 'web_m2x_options' module for that

Solanki Shamji India
15. 10. 15. 오전 5:54

Try widget="selection". I edited answer.

Sairam Bandaru India
15. 10. 15. 오전 6:29

If we use widget="selection" then name_get won't call on that field and it will return all the data at a time Now issue reolved by installing the web_m2x_options thanks

Solanki Shamji India
15. 10. 15. 오전 6:30

Njoy

3
Avatar

Ankit H Gandhi(AHG) India

--Ankit H Gandhi(AHG)--

1439
| 6 5 8
Baroda, India
--Ankit H Gandhi(AHG)--

Learning Python..

Ankit H Gandhi(AHG) India
17. 5. 25. 오전 7:03

Please use below code.

<attribute name="options">{'no_create_edit': True, 'no_create':True, 'no_open':True}</attribute>

or 

<attribute name="widget">selection</attribute>

I hope this help you.

Best Thanks,

Ankit H Gandhi.

0
Sehrish Pakistan
18. 4. 26. 오전 2:16

Try this one,

<field name="your_field_name" options="{'no_quick_create':True,'no_create_edit':True,'no_open': True,}"/>

Read more: https://www.youtube.com/watch?v=X_sdiKGQgJo

0
Dr Obx United Kingdom
15. 10. 15. 오전 5:55

 

<should work on any type of field options="{'no_create': True, 'no_quick_create': True, 'no_create_edit':True}"/>

 


질문하기
Writer
Keep Informed
1 팔로워
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now