Odoo Help

0

0
2 Answers
0
Nalini R. Wale
2019/02/21 7:18

Add
        client_max_body_size 30000M;
        client_body_buffer_size 200000k;
this 2 options in etc/nginx/sites-available/default or etc/nginx/nginx.conf whichever is applicable

0

Hi John,

answer is a bit late, but for the sake of closure: this problem is related to your NGINX config. As you know, NGINX config is a little bit tricky, but basically you can enter parameters on http, server and location levels. So somewhere in your NGINX config (e.g. in /etc/nginx/nginx.conf for http level or in /etc/nginx/sites-enabled/<HOSTNAME>.conf for server level, look for this line:

    add_header X-Frame-Options DENY;

and replace it with this line:

    add_header X-Frame-Options SAMEORIGIN;

and restart nginx. Remember to check the nginx documentation, bcause if you change this setting on http level, it will affect other sites on the server as well, and if you add the add_header command on server level, nginx will ignore all add_header directives that you entered on http level.

Solution drawn from: https://github.com/odoo/odoo/issues/18137#issuecomment-459706730

Ask a Question
Writer
218
John
Keep Informed
1 follower(s)
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our eLearning platform and experience all Odoo Apps through learning videos, use cases and quizzes.

Test it now