Odoo Help

0

1
13 回答
1
Antonio M. Vigliotti イタリア
2014/12/04 12:46

Hi,

you should change 2 files.

in ./point_of_sale/static/src/xml/pos.xml you should change pos-ticket object

in ./point_of_sale/static/src/css/pos.ccs you should:

  • add new left-align class
  • set width 88%
  • set margin to 0 (but this works well just with Chrome)

You can download file here https://github.com/antoniov/Odoo-Italy/tree/7.0

All the diffrences are marked as [antoniov]

 

Hope this help

Antonio Maria Vigliotti

0
Jerry Bhattarai ネパール
2017/07/06 8:42

Before making any changes first click on Print Receipt >

the on print preview page > go to more setting then Finally set

"Scale = 70" in print preview page.


Will work .

0
agb80 メキシコ
2014/05/22 13:42

If you use this soft https://github.com/Fedrojesa/ProxyPoS you can use directly EsC/PoS templates for generate the receipts forgeting about CSS and other weird situations with printed receipts.

2 コメント
Faheem Khan パキスタン
2015/09/08 6:22

how to install proxypos in openerp @agb80

agb80 メキシコ
2015/09/09 11:57
Hello Faheem,

ProxyPoS is not mean to be installed on openerp but on the box you are going to be used properly as Point of Sale. The intention is to intercept the communication OpenERP PoS try to do with a server sending the information for interact with the PoS devices.

On 08/09/15 05:22, Faheem Khan wrote:
<blockquote cite="mid:1441707731.498382091522217.424540075546407-openerp-52798-forum.post@accounts-a.odoo.com" type="cite">

how to install proxypos in openerp @agb80

M. Faheem Khan

+923324647347

Sent by Odoo S.A. using Odoo about Forum Post False
0
アバター

Thierry Godin フランス

--Thierry Godin--
1591
| 8 7 10
Collegien, フランス
--Thierry Godin--

..

Thierry Godin フランス
2014/05/21 8:38

Hi,

I do not use this printer, but in my company I do configure POS receipt printers with this settings (in Firefox) :

Scale = 88% (play around here to fit the ticket)

Uncheck "adapt to page size"

Margins : 0 , 0 ,0 ,0

Footer/header page = nothing

Hope this helps

0
Michael Herzog ドイツ
2014/05/21 6:25

Hi there. For me it worked when I added "@page {margin:0;}" in the pos.css. 

 

質問する
Writer
Keep Informed
4 フォロワー
About This Community

This platform is for beginners and experts willing to share their Odoo knowledge. It's not a forum to discuss ideas, but a knowledge base of questions and their answers.

Register
Odoo Training Center

Access to our E-learning platform and experience all Odoo Apps through learning videos, exercises and Quizz.

Test it now