Help

0

Odoo is ignoring point as decimal separator

Avatar
José

Hello, I have updated 8 from 20150331 version to 20160427 version. I am using all the modules from the new version. 

After the update, I have the problem that when I am doing a SO or a PO, or any other document, when I put in the price "6.35" (for example) and I focus out I get "635". If i put "835.33" I get "83533" so, Odoo is ignoring the point as decimal separator. Previous to the update, it works fine.

How can I correct that? Thanks!        

アバター
破棄
6 回答
0
Best Answer

Hi Jose, Did you find any solution?

アバター
破棄
0
Avatar
José
Best Answer

I detect the problem, in Settings -> Translations -> Languages I have "." as thousand separator and "," as decimal separator.

Can I keep these values and use the dot of the keyboard number as decimal separator, like in OpenOffice Calc? 

Thanks!

アバター
破棄
0
Avatar
Prakash
Best Answer

just ensure a basic thing:

Enable Technical feature :Settings -> Users -> Select user and under access rights tab check technical features
Check the Decimal Digits: Settings -> Database Structure ->Decimal Accuracy

http://prnt.sc/b0uh0k



2 コメント
アバター
破棄
Avatar
José
-

Yes, it is OK. I have 2 decimal digits.

Avatar
José
-

If I put "6,35" I get the correct value. But if I use dot, not works. Previous to the update, dot and comma works.