Help

2

How to enable debug mode in "website_" modules?

Avatar
sepdau

How to enable debug mode in webiste_ module?

Is there any solution for that situation because I just want to debug.

Thank in advance!

アバター
破棄
2 回答
2
Best Answer

Just add to the end of URL:

?debug 
3 コメント
アバター
破棄
Avatar
Ermin Trevisan
-

I can't see any effect. How should that work?

Avatar
Andreas Tolstov
-

If you look at JS in Developer Tools of your Browser, its not compressed.

Avatar
Ermin Trevisan
-

Now I see, thanks.

1
Avatar
sepdau
Best Answer

I found the fastway to do that. enable debug mode default. 

Notice: Should use only dev mode :D

openerp/addons/base/ir/ir_qweb.py

def render_tag_call_assets(self, element, template_attributes, generated_attributes, qwebcontext):

        """ This special 't-call' tag can be used in order to aggregate/minify javascript and css assets"""
        name = template_attributes['call-assets']

        # Backward compatibility hack for manifest usage
        qwebcontext['manifest_list'] = openerp.addons.web.controllers.main.manifest_list

        d = qwebcontext.copy()
        d.context['inherit_branding'] = False
        content = self.render_tag_call(
            element, {'call': name}, generated_attributes, d)
        bundle = AssetsBundle(name, html=content)
        css = self.get_attr_bool(template_attributes.get('css'), default=True)
        js = self.get_attr_bool(template_attributes.get('js'), default=True)
        # return bundle.to_html(css=css, js=js, debug=bool(qwebcontext.get('debug')))
        return bundle.to_html(css=css, js=js, debug=1)

アバター
破棄