Help

0

Report problem when accessing Odoo with port 80

Hello,

I installed Odoo on CentOs VPs using this link . All things was fine. But when I'm trying to print any report

it appears with different strange format just like this one. I changed the wkhtmltopdf to version 0.12.1 but the

nothing changed, I found this question and I thought it is a port issue .. then I tried to access the server via ip:8069 . and the

report format changed to the usual format. I also tried this on the local machine running Ubuntu 14.04 and also with a machine running Ubuntu 12.04. the problem appear when I set the iptables rules I used these rules on Ubuntu:


sudo iptables -A INPUT -p tcp --dport 5432 -i lo -j ACCEPT
sudo iptables -t nat -I PREROUTING -p tcp --dport 80 -j REDIRECT --to-port 8069
sudo iptables -A INPUT -p tcp --dport 8069 -j ACCEPT
sudo iptables-save


I hope if any one has a clue to solve this issue ...

Avatar
Abbandona
5 Risposte
0
Migliore risposta

Hi, I Solved it by using Apatche server ...

Avatar
Abbandona
0
Avatar
Jasad Moozhiyan
Migliore risposta

Hi,

Please try with nginx reverse proxy server.

http://www.technaureus.com/how-to-run-odoo-on-port-80/

http://www.technaureus.com/how-to-setup-nginx-for-odoo/


Avatar
Abbandona
0
Avatar
ESLAM ElGINDY
Migliore risposta

use nginx  it will fix it to you 

Avatar
Abbandona
0
Avatar
Andre
Migliore risposta

Hi,

not sure but try the following:

Activate "Technical Features" for your user. Refresh your site (F5) and
go to Settings->Technical->Parameters->System Parameters.

Now change web.base.url to your odoo adress and your port (http://localhost:80).
Andre

1 Commento
Avatar
Abbandona

Hi Andre, Thanks but It seems that it doesn't work ....